Driver Problems in Windows 10 transfer

I have a 2015 Macbook Pro, and on that machine I was running Windows 10 externally with a Samsung T3 SSD. I recently upgraded to Winclone 8 and prepared to transfer my Windows install over to my new 2019 27" 5k Imac. I cloned the drive and started following instructions similar to the 2 migration tutorials under the Winclone 8 section of the knowledge base. I wanted to use the same external T3 SSD on the new Imac

I got to a point after putting some files on the USB to just try boot Windows from the external on the new machine. To my surprise, it worked. I then ran the boot camp software and did the “repair” option and I am up and running.

I can’t seem to get the headphone jack to work properly and I also noticed that my USB-C port isn’t working with a different SSD, althought it IS working for an external monitor.

My question is, should I just do a fresh install of Windows at this point? Is there any way I can delete my drivers and re-install them? What do you think is the best course of action

Thank you in advance

You can try running sysprep, which will force windows to redicover hardware. You can also remove drivers in device manager and reboot and then they should be rediscovered.

tim

1 Like

I have no specific answer to your question. But I can share some of my experience with an external SSD (Samsung T5) that carries a Win10 Bootcamp partition. After some troubles getting Win10 Bootcamp to work, I did a sysprep and executed WinClone to the external SSD. It all worked well after that, including the audio. I use the Samsung SSD on my 2017 MacBook. I was surprised when I tested it on my spouse’s 2014 iMac to find it worked perfectly well without any changes.

Regarding the USB-C ports, of which I have 2 on my MacBook, I find their behaviour sometimes a bit strange. For Win10, I like to use a USB-3 mouse instead of the Apple Magic Mouse because of some issues regarding my left handedness. If the USB-3 mouse is connected to the dongle when I start up Win10, the system doesn’t recognize it - the mouse seems not to be powered on. But, after Win10 startup is complete, if I unplug the dongle from my MacBook and plug it back in after a few seconds, the USB mouse powers up, the tracking light comes on, and it is recognized by Win10.

2 Likes

I might have to try sysprep. That is in the windows installer right? Will I have to “inject” the drivers?

Also, How am I supposed to update this if it’s an external. The windows updater doesn’t like that…

G’day

Sorry It’s been a few months, and I don’t remember the details. What I do remember is the following :

  • Sysprep is executed from Win10, so your default disk is already the external disk from the point of view of Win10. Once sysprep executed, I rebooted Win10 from the external disk as per usual. The installation was stripped of my personalized parameters, but otherwise OK.
  • I did not need to reinstall drivers.
1 Like

OK… I’ll try run sysprep

How are you updating your current computer? I cannot get windows updater to work since it is an external drive?

This wasn’t an issue for me, so I have not tried it.

If I remember, I managed to get a sysprep off the internet and executed it directly in Win10. I presume the reason you are referring to an update is to get sysprep. Correct me if I am wrong,

My Win10 external SSD works well. In addition, It handles automatic Windows system updates (for security purposes) without any problems.

I can send you a copy of sysprep if you need it. Seems to me it wasn’t too big. I can put it on Google Drive and send you a link.