External drive question


March 20, 2017 you explained how to “Migrate Windows 10 Anniversary Edition to USB-C External SSD”. During that explanation, you stated a step: I then took my Samsung T3 USB-C SSD, which I formatted as an EFI partition scheme with 2 partitions (HFS+ and FAT32).

Could you explain how you format a EFI partition scheme with 2 partitions (HFS+ and FAT32?

Thanks Tim!


I guess my question is…What’s the purpose of the HFS+ partition? How big should it be? I already know the FAT32 is where Windows will be located.

Thanks! Jake

I don’t know, but I assume the point is, use NTFS for Windows, and use HFS+ for everything. If you use a single partition, it will wind up being NTFS for the whole drive.

But clarification would be appreciated.

Hi 3dmark!

I appreciate your comment!
Your assumption is correct. Why would you need HFS+ on the external drive? Hopefully, Tomothy will chime in fairly soon.

With Windows “Creators Edition”, I’ve been successful in getting the external drive to boot, but the “start” menu is not responding. A problem Tim is aware of already. I haven’t had time to work on the “experimental” fix yet.

Once again, I Thank You for your response!


1 Like

I tried following the guide that @Jake linked, but no luck.

I note that when restoring to the external drive, I got the block size error message (and hit continue):

When booting into Windows on the external drive, I get this error message:

I’ve spent hours on variants of this process with no success - getting really close to calling it a day and giving up.


Don’t use the “block” option…use WIM (file based)!
Heading to Church…I’ll check back!


Yeah, I tried using WIM, same problem. Ah well. Thanks for the help.

Did you create the image with the WIM option selected? The image needs to be in WIM format to avoid that issues. You also also not see the dialog if the image is in WIM format and there is a block mismatch.


+Hey Tim,

What about your process of formatting the external drive? What is the HFS+ partition used for?

Thanks in advance!

The HFS+ partition is not needed. I guess I was just used to having it for data storage and for macOS when installed internally.


Hey Tim!

Thank You! I appreciate the clarification!
Take care!


Hi @tperfitt, I tried the entire operation from the beginning again, making sure to use WIM format. Unfortunately, I still am getting that error when I try to boot into Windows.

The inaccessible boot device means that the EFI firmware can’t find that the device. Is it the Samsung T3? I have also heard of the Porche SSD working as well (though not sure if it is USB-3–I suspect it is).



Does the new update fix Winclone with Windows Creators Edition?

Unfortunately, no. Using block based cloning, if possible, is still the recommended course of action.


Goodness! I’m confused! I thought with Windows 10 we were directed to use file-based WIM. Oh well, hope I don’t need my BootCamp backup before the fix. Wish I hadn’t updated to Creators Edition!

Please, Please announce when it’s fixed! Thanks Tim!

The issue has now been resolved! See:

for more info.