Macbook Pro 16 inch

Hi Tim,
I was able to do the most of the cloning process to the new Macbook 16". During startup at the command prompt, I am not able to address “c:/winclonefix.bat”. It shows me a pre-set like X:\sources> and I don’t know how to accomplish this last step from cloning my windows 10 image. I was not able to find any help for this topic online. Can you please help to get this addressed>? Thanks

you should be able to type in:


and it should run the script.

I am having problems my new Macbook pro 16 10.15.3 injecting the drivers. I have imaged and restored using Winclone 8, but I am stuck trying to get into the DOS cmd prompt using the Fn key to display f10 is not working. I have no response from the keyboard or touchpad and have redownloaded the Apple drivers.

I am using the lasted Microsoft windows 10 1909 iso and using Bootcamp 6.1.0.

What can I try?



Drivers for keyboard still not loading after several minutes, but I found an old wired keyboard to run the command.

I am now on error 21 unable to access image
make sure that the image path and the windows directory for the image exist and you…

can you do a dir c: and a dir d: and see if those volumes are accessible?


Hi Tim,

I was able to figure out a couple of things to get thru:

Keyboard and Touch pad did not work. So, after a few forum searches, I ended up finding a wire usb keyboard, which did allow me to go into the cmd prompt. However when running the winclonefix.bat it said it could not access/find directory.

So, after another search, it looked like the culprit was the usb hub I was using had SD card slots that changed the default drives. I happened to have a single usbc to usb adapter and used that to efi boot, and my other usb c hub had the usb keyboard. Keyboard and mouse on laptop did not work still.:frowning:

I was finally able to run the winclonefix.bat successfully and booted into the Windows 10. My bootcamp windows drivers did not install correctly, and I had to manually install the network card manually to get the wifi up and running. I still have not figured out what these NCM data, and NCM control drivers are at?

Mental note before anyone goes down this road with the New Macbook pro 16, buy 2x usb c to usb adapters first. A 16g usb flash drive, and an external hard drive to store the Winclone 8 image.

Tim, @tperfitt ,

Question when doing this - I’ve successfully created my backup of windows 10, I also dragged every file to the flash drive - it contains everything in the demo. When I boot, I get to the windows screen but my keyboard and mouse do not work. I even tried plugging in a wired keyboard (which has been tested and working) and that didn’t work either. I’m stuck on the windows install screen and cannot open the command prompt to move any further.

Any advice?

Gaets Juliano

@tperfitt so I actually resolved the issue. I used a 32GB flash drive instead and for some reason the drivers now loaded enabling me to load the command prompt. I am now met with the following error when I type in the command of c:\winclonefix.bat.

I’ve attached a picture - it says “error: 21 Unable to access image”

the script assumes that D: is the boot camp partition, though it is possible it is another drive letter if there are other partitions/disks available. If you do a dir on common drive letters, can you find the boot camp mounted volume:

dir c:
dir d:
dir x:
dir e:

Also, it could be that the AppleSSD drive was not loaded, which would be why it can’t be seen. Verify that you are using the correct drivers for this machine and that AppleSSD driver is one of them. You can also manually load it with drvload.


Appreciate the reply!

I tested the four drives you have posted and I’m thinking my bootcamp partition is “X”. See the attached screenshot to confirm. “C” showed me the contents of my flash drive so It definitely isnt that.

The AppleSSD driver was taken from the bootcamp support folder and I’ve confirmed it’s in the right place. This is a new 16" Macbook Pro fresh out of the box.

Let me know what I need to do to get the script to look at X: or do i need to re-associate my partition to drive d: ?

*EDIT - Uploaded image

**Edit x2 - @tperfitt I can’t reply because it says new users are limited to 3 replies so I’m editing my response here to reply.

***Edit x3 - I think the issue was that my flash drive was connected via a USB C Hub that contained multiple ports (HDMI, SD, Micro SD - I saw someone else commented on this). I reconnected with a small little dongle and it loaded correctly. The hub connected through two of my USB c ports (maybe something worth noting) I was able to get in and now running the bootcamp repair files.

All is good! Thanks for the help!

The driver was successful but it still says drive d is not ready. I uploaded the new screenshot.

The issue is that the applessd drive didn’t load, so it can’t mount or map to d:. To manually load the driver, run:

drvload c:\AppleDrivers\AppleSSD.inf

(you may have to adjust the name / path but I think that is correct based on the screenshot).

If it returns without error, run

dir d:

and if you see the boot camp partition files, run the script again.


Hi, I am back.

It looks like Winclone 8 has matured to the point that it is usable again with the 2019 16 inch Macbook Pro.

Given the state of the industry, it would have been nice if Twocanoes had been a bit earlier with it’s testing using the new hardware.

Since that wasn’t done, a large notice on the download page indicating something to the effect: “We have not had a chance to verify Winclone functionality using the 2019 16 inch Macbook Pro. Until that functionality is shown to work, please do not use Winclone when the 16 inch Macbook Pro is your destination Windows system. We are working hard on providing a functional solution, and apologize for the inconvenience”.

So, a few months late, but it looks like most of the issues are worked out.

Booting off of a USB thumb drive is still quite error prone, and I suggest you completely automate that process.

I see you added the automation of injecting the SSD drivers. Why not inject all the required drivers (Keyboard, Touch Screen, etc)?

I will be repurchasing the license, since there is no other product with similar capabilities.

I am still having issues with Paragon’s filesystem drivers. I am able to reliably crash my kernel when accessing ext4 filesystems (Linux).

Winclone never caused any issues in regards to the MacOS system crashing, or otherwise being corrupted.

I haven’t tried booting the Mac natively in Linux, that will be the next ‘project’.

For the life of my I cannot see why Windows insists on eating up 30 GB of disk space for a ‘hiberfile’. I have to disable this everytime a boot.

Welcome back! I have been working on Winclone 8.2 that allows you to inject drivers for SSD, keyboard and trackpad directly from Winclone:

Let me know what you think and if it works for you.



I posted a new topic regarding a missing wifi driver recently but now that I do a bit of digging it appears there are more problems than that. I followed all of the driver injection instructions, they worked fine, but when I run setup.exe there is an error and the drivers do not install. I wiped the partition, recloned, and tried a second time, same problem.

Any help would be amazing as I want to pull my hair out.


Try going into the Drivers folder and installing the drivers individually and see if that is more successful.


1 Like

I really need some help !

I am migrating a Windows 10 Bootcamp partition from a Macbook Pro 15" (2013) to a new Macbook pro 16" (2020).
Using Winclone 8.2 i’ve been able to backup the source Bootcamp and to restore it to the target Bootcamp partition with no errors.
I have tried to inject driver from the Winclone menu “Add AppleSSD Driver”. It seems to find the drivers :

but i successively get 2 times the same error message :

and i finally get a successful completion message.

But when i try to boot in the Bootcamp partition, the Windows logo appears on the screen and it fails with a blue screen.

I have also tried to use Bootcamp through Parallels, and it works perfectly !!!

So, what did i miss ?

Can you please help me to fix my problem ?

Can you look in /Volumes/BOOTCAMP/Windows/System32/Config and see what files are in that directory?


Here is the content of the directory :

Thanks !

I’ve successfully transferred my mid-2009 MacBook Pro 17" Core 2 Duo running
Windows 10 (1909) Home via boot camp to my 16" i9, all internal partitions.

It took a lot of time to make this work, and the Winclone 8 software
helped immensely here. Thank you to the team! I overcame several unexpected
and a few commonly mentioned problems, and now everything I need is working.
(I don’t have any thunderbolt accessories to test, only USB3)

I already owned Winclone 5 from 2016. By reading the information published
here, I decided to try this using Winclone 5 to Winclone 8 for doing the
transfer. I first cloned my boot camp Win10 installation from El Capitan.
No Sysprep or anything else was prepared on my normal setup before imaging
about 500GB. The MBP17 has a 1TB SSD, 8GB RAM, and Win10 upgraded recently
from Win7, and way earlier from Vista. Using unofficial and ad hoc sets of
Win10 drivers. Winclone 5.7.6 is freshly installed from this site.
The image creation took about 6 hours via USB2 to an Orico case holding
a 1TB 5400RPM 2.5" HGST drive, creating a 300GB boot.img.gz on exFAT.

Spent much time experimenting with multiple attempts and trying various
things until I successfully got my files onto MBP16’s SSD partition installed
using Winclone 8. I did not succeed with my one attempt at booting into the
recovery, or changing any EFI boot settings; I didn’t need to do that.
Windows 10 booted the first time, wow! :star_struck:
But it began blue screening after running a short while, and not every
device I needed was working, including the WiFi. :anguished:

After I resolved the crashes and all devices including WiFi and touch bar
are working, I upgraded my Windows to 1909 Pro version.
It’s been running rock solid with mild use so far, and even runs
games from Steam. :partying_face: