.../run on Create Bootable Volume Not Working

#1

/Volumes/Volume Name/run does not work for us when on the same Create Bootable Volume and booted from it into the installer. Should it? Are we doing something wrong? We have lots of machines without recovery partitions, so we need to go external boot route. Tried with 10.14.4

If we install MacOS on a external (regular OS installation not Create Bootable Volume) and then MDS - Save to Volume, and boot into a normal OS, were OK.

Thanks!

1 Like
Error when running from USB
#2

I just added an update to the admin guide that addresses that issue:

(section name is Running Workflow):

Running Workflows from External Volume

If you are saving an MDS workflow to a bootable external volume, be aware that the macOS installer presents the volume name as “/Volumes/Image Volume” rather than /Volumes/. This can cause issues with the workflows since the resources are accessed by the volume name. To resolve this, you can do one of two solutions:

  1. Create two HFS+ partitions on the external drive. Install the bootable macOS on one partition, and save the MDS resources to the other partition. You can then run the command using /Volume//run/
  2. After installing macOS to the external volume, rename it to “Image Volume” then save the resources from MDS to the Image Installer volume. The workflow resources will then be referenced by the correct name and you can run the workflow by running /Volumes/”Image Volume”/run
1 Like
#3

Solution 2 works great! Thanks for the details.

1 Like
#4

@tperfitt I see my earlier post is redundant to yours :crazy_face: however it has been my experience that spaces in the volume name are problematic. FWIW my reco is to have your second partition be a single contiguous text string (I used “MDSAssets”).

Nice work on this thing…been looking for something to replace most of the early deploystudio stuff we used to use all over the place. getting there :slight_smile:

1 Like