0xc000000f Error after migrating Win 10 from real PC to Early 2015 MBP Bootcamp, Adata NVME SSD

I’m trying to migrate my old real PC Win 10 Pro install to a Bootcamp partition on my early 2015 MBP 13" with macOS Monterey 12.1, but I’m running into some issues. I’ve upgraded the MBP SSD to an ADATA - XPG SX8200 Pro Series 2TB NVME drive using a Sintech NVME adapter. I’ve currently got the Winclone 10 Standard license.

What I did:

  1. Followed the steps in Migrating a Real PC to Boot Camp – Twocanoes Software through step 2. Step 3 doesn’t exactly match Winclone 10, so…
  2. Created an image from the PC SSD using Winclone 10 and saved that to the macOS partition of my Adata drive (Create Image from Volume with Winclone 9 or later – Twocanoes Software)
  3. Tried starting Win 10 on Bootcamp up; INACCESSIBLE_BOOT_DEVICE error. So, I tried injecting drivers with Winclone using the following: https://twocanoes.com/knowledge-base/inject-applessd-driver-in-winclone-9/
  4. Ended up with an 0xc000000f error when trying to boot Win 10 on Bootcamp.
  5. I wasn’t sure if there was an issue with injecting the drivers using Winclone, so I tried the steps on https://twocanoes.com/knowledge-base/resolving-inaccessible_boot_device-error-after-restoring-winclone-image/ and in the cmd prompt after trying the dism command, I got Error: 1812 “The request is not supported.”
  6. I attempted using the Windows setup from the EFI boot (Windows Recovery USB from the previous instructions) to install the drivers onto the Bootcamp partition, manually going into each of the $WinPEDriver$ subfolders and installing what was there. Same 0xc000000f Error.
  7. Thought maybe the issue was my non-Apple OEM SSD. Did some searching, and it turns out Adata does not have it’s own driver for this M.2, and instead just uses the native Win 10 NVME drivers. So no driver to install–shouldn’t it just work with Windows native? Or is that the issue? Not sure where to go from here.
  8. Looked at all the other threads on 0xc000000f and Adata XPG NVME issues, and none of the suggestions there seemed appropriate or helpful.

Any ideas?


I think you are on the right track. The issue is probably the drivers for the drive. I would try installing windows directly on it and verify that that works.


Do you mean just do a regular bootcamp install of Windows on the new drive, then see if it boots? I’ve done that a few times and it works fine. It’s only when I try using Winclone to bring the image of the old PC on the bootcamp partition in place of the clean install. Or do you mean something else?