Amdkmpfd.sys failed

Trying to migrate Bootcamp Partition from my 2018 MBP with Radeon Pro 560X graphic card to 2017 iMac Pro with Radeon Pro Vega 64 graphic card then I got"

What failed: amdkmpfd.sys

Solution 1:

  1. Winclone Image ran Sysprep already
  2. Created Bootable USB following THIS LINK
  3. Injected Drivers following THIS LINK
  4. Problem persists

Solution 2:

  1. Following THIS LINK, I partition and install the Windows by Bootcamp Assistant, then restore the Winclone image
  2. Problem persists

Solution 3:

  1. Following THIS LINK, I created another Bootable USB and tried to inject the drivers.
  2. Problem persists.

Solution 4:

  1. Tried F8 and Shift+F8 to boot into safe mode in Windows, but no success.

Solution 5:

  1. Holding Shift while booting into Windows, Asking me to select language but my mouth and keyboard is no responding, even wait for 15 minutes.

You may want to try booting the Boot Camp partition using a trial of VMWare Fusion, removing the driver in device manager, then rebooting into the Boot Camp partition.