Automatic boot on schedule not working


#1

Setting a boot schedule for Windows via config profile is not working, unclear why. Simply, nothing happens at the designated time.
Expectation based on settings: come 1am system would reboot to Windows if sitting at bootrunner screen.

schedule


#2

I just tested this in the latest Boot Runner 3 and it worked fine. Here is what I did on our test iMac:

  1. Set up the settings like you did above, but I put in disk1s4 instead of disk0s4 (since diskutil list showed that the boot camp partition was on disk01s4). I also set the time to start into Windows at 4 pm and then I set the clock to 3:55 pm on the Mac. I also set it to be a 10 second countdown since I am impatient.
  2. Installed the profile and logged out.
  3. At 4 pm, Boot Runner did a 10 second countdown and selected the Windows partition and boot into Windows.

I suspect the issue is either the disk0s4. Try using the name that shows up in Disk Utility as the Boot Camp volume name. You can also try looking in “diskutil list” and finding the device number to verify if disk0s4 is your boot camp partition.

tim


#3

I don’t think that’s the issue in the test case…

36%20PM

That said, I checked a couple systems, and pending tech the partition does move around. However, it looks like it’s always named “Windows” (these are all deployed with Winclone). I’ll try using “Windows” as the volume as that should be more universal, but it seems like there is another issue in play here even if I work around it.


#4

If you are using Boot Runner on a dual boot Mac inside a TARDIS, I doubt it would work due to the time and space fluctuations :wink: .

The log might be help as well since it will print what a volume is (or is not) selected. You can get it this way:

log show --style syslog --predicate 'process contains[cd] "Boot Runner"' --info --last 2d

(you can adjust the argument of “2d” from 2 days to other time periods that you want the log, like “10m” for the last 10 minutes or 3h for the last 3 hours).

tim


#5

The problem appears to be that Boot Runner just goes to sleep at some point. The energy settings are never sleep for the system, but in testing this overnight (desired deployment setup) the log indicates Boot Runner went from constantly spamming the log to dead silent from just after 7pm until I came in and touched the mouse this morning. It would seem because of that, it didn’t trigger the reboot at 1am per settings. This would appear to be a deficiency. Is there a way to keep Boot Runner from sleeping so it does the middle of the night reboot?


#6

I’ll see if I can replicate on this end. Did you other system log entries during this time period? Did the log show a sleep/wake event?

tim