Boot Runner v3.2 - I end up back at the BR menu?

Hi. I had a problem with BootRunner that I thought I had solved yesterday (See thread with title keyword “stumped”) by installing V3.2. However, this morning, when I clicked on an SSD with Windows 7 Ultimate installed, the system restarts but Windows does not and after a few minutes, I end up back on the BR menu.

I have entirely disabled SIP.
I uninstalled and re-installed BR V3.2. I still get this same issue and cannot boot into Windows 7 anymore.

Not sure if this is helpful: Since writing up this support request, I tried booting into Win7 via Paragon’s NTFS for Windows/Startup and now get the following message: The operation couldn’t be completed. (Mach error 5 - (os/kern) failure).

Any suggestions please? Thank you.

I can now boot into Mojave or Win7 Ultimate from BR.

However, I am not quite sure how I fixed this, but I will offer the following observations:

  1. I uninstalled NTFS for Mac as a precaution, given the error message I was getting that I listed earlier (I also got additional message around bless not working while exploring why this was happening).

  2. I set BR to use the Legacy boot (partly out of fear of the reported problems with Windows EFI on pre-2013 Macs corrupting a Mac Pro’s firmware by signing it with multiple Secure Boot certificates - X.509).

  3. For some strange reason, SIP sometimes is re-enabled on the Mac Pro when I power up. The following command csrutil enable --without nvram doesn’t seem to “stick”. What I mean by this is that when you do a shut down (complete power off), it seems that SIP may revert back to enabled completely (i.e. without nvram disabled…everything shows enabled when running the status command). I tested this several times by doing a complete shutdown and sometimes, when doing a power up the SIP will reset to completely enabled. I did not do a PRAM at any point in my testing. This seems random, as on the 3rd power-up test, SIP was again enabled, so I ended up disabling SIP completely. I found several threads on this issue with SIP for Mojave in various forums.

I documented what I did in case another user runs into the same issues.

Thanks. It does seem related to the Mac Pro and we are investigating.