Boot runner won't run!


#1

I just installed the latest version of Boot Runner on my OSX Mac. Restarted my Mac and it booted straight into Windows (Bootcamp partition) rather than boot runner.

Thought I might have to add the bootable drives in the Boot Runner Config menu, so did so. Restarted my Mac, and again it boots straight into Windows.

So Boot Runner doesn’t seem to be working for me. If I hold down the option key on startup I can choose my boot system (though via the native Mac method, not Boot Runner). Any help appreciated.


#2

After installing boot runner, set the macOS as the startup volume, and turn off auto login (if it enabled). Boot Runner will show over the login window.

tim


#3

Hi, thanks for your reply. I tried that and unfortunately it didn’t work. I tried setting the macOS start-up volume as the one that seems to be suggested by the Boot Runner Config app (disk0s4 is there in light grey), and also as the one which appears if I click on the Boot Runner icon on the taskbar (disk1s1). In either case, the machine just boots straight into Windows (Bootcamp) when I restart. See pic for what I tried:


#4

I see the issue. you have put in “automatically select volume” so when Boot Runner comes up, it will select the Windows partition and reboot. Try removing that entry.

tim


#5

Hi, thanks for your reply.

I’m a little confused. In your first message you told me to set the macOS as the startup volume, but in your last message you told me to remove the automatically selected volume?


#6

Stil looking for some advice here, if possible :expressionless:


#7

Sorry for the confusion. I mean to set the Mac volume in the startup disk in System Preferences. This will cause the Mac to boot into macOS, and Boot Runner will be shown over the login window. When the Windows volume is selected, the Mac will reboot to Windows. Boot Runner sets a flag to reboot back to Mac on the next reboot, so when you are done in Windows and reboot, the Mac will return to the macOS side and show Boot Runner.

tim


#8

Thanks. Do I have to enter anything in the Boot Runner Config window (e.g. put in items under the “Volume and VM Configuration”?


#9

You only need to enter those values if you want to customize the look and feel.

tim


#10

I set the Mac OS as the default startup option in system preferences, and left the options in Boot Runner blank - but on restart it still just boots up into OSX (Apple icon with loading bar, then Mac login screen, then desktop). What am I doing wrong?


#11

You need to disable automatic login in Users and Groups->Login options. If you log out via the Apple Menu, does Boot Runner appear?

tim


#12

Hi, sorry for the delay in my reply - been pretty busy!

Boot Runner is still not working for me. I can start the Boot Runner Config app and it shows in the menu bar. When I restart my Mac, Boot Runner doesn’t appear and it just boots into OSX. If I select the other volume (Bootcamp) from the Boot Runner Menu, OSX simply restarts instead of Bootcamp.

I have automatic login set to “off” in the “users and groups” menu of the OSX system preferences. My Boot Runner Config App looks like this:

And the users and groups menu:

Any help much appreciated!


#13

Are you using full disk encryption / File Vault 2? That automatically logs you in. You can disable it by doing this:

tim


#14

Hi, thanks for your reply. I followed the instructions in your link and it is disabled. Boot Runner is still not working for me though - when I restart, it seems to boot into the Windows (Bootcamp) partition by default. If I hold down the option key on reboot, then I get the OSX menu where I can choose OSX or Bootcamp. Automatic login is off, and my Boot Runner Config menu is still as per the above.


#15

Boot into the Mac side, and set the startup disk for the Mac. When Windows is selected in Boot Runner, it will boot to Windows just one time, and the return to the Mac side after reboot.

tim


#16

Hi Tim,

When you say “set the startup disk for the Mac” - do you mean in the boot runner config app or in the OSX settings?

You say “it will boot to Windows just one time, and then return to the Mac side after reboot” - I don’t want it to return to the Mac side. I want to get the Boot Runner screen, so I can select which OS to use.

Any further help appreciated.


#17

Boot Runner runs over the main login window on macOS. Here is how it normally works:

  1. Mac boots up
  2. Just before the login window is shown, boot runner is shown full screen over it.
  3. If you select the Mac startup volume, Boot Runner hides and shows the login window.
  4. If you select Windows, the startup disk is set to boot to Windows one time and the mac is rebooted.
  5. On reboot, Windows is booted.
  6. When windows is rebooted, the startup disk reverts back to Mac and macOS boots up.
  7. The Boot Runner screen is then shown over the login window.

tim


#18

Hi Tim,

Thanks for the further info.

I uninstalled Boot Runner and then reinstalled my previously purchased version (Boot Runner 2). This time, it booted into Boot Runner (hooray!). I could however not boot into Bootcamp as SIP was enabled.

I learned from another post of yours that Boot Runner 3 does not require SIP to be disabled, so I downloaded a trial of that. After installing, I rebooted - and now the Boot Runner screen appears, but it says that I cannot access Windows because the SIP is enabled!

I then learned that you still need to kind of disable SIP by entering the following into OSX terminal during recovery mode:

csrutil enable –without nvram

Running that command however gives the message:

csrutil: requesting an unsupported configuration. This is likely to break in the future and leave your machine in an unknown state.

Is this expected?

Thanks


#19

yes, that is expected. Apple does not allow selecting a startup disk programmatically without partially disabling SIP.

tim


#20

OK, I see. Another thing - my Macbook’s internal HD is no longer listed under “storage” on my MacBook (i.e via main menu/about this mac/storage). Is this expected with the above command?