Bootcamp & Mojave on iMac 27" late 2014 with 3TB fusion drive

Apple says to remove the Bootcamp partition and then reinstall WIndows. There’s a post in Apple’s Support forum that says one person just installed Mojave without removing the Bootcamp partition and it worked. What would you advise?

The issue is core storage. Fusion drives are converted from corestorage and HFS+ to APFS. If you have a 3 TB fusion drive and it was split up with core storage, then you could have issues, though it could work depending on the configuration. Can you send the output from this command in terminal?

diskutil list


diskutil cs list


[Memory-Alpha:~] djh% diskutil list

/dev/disk0 (internal, physical):


0: GUID_partition_scheme *121.3 GB disk0

1: EFI EFI 209.7 MB disk0s1

2: Apple_APFS Container disk2 121.1 GB disk0s2

/dev/disk1 (internal, physical):


0: GUID_partition_scheme *3.0 TB disk1

1: EFI EFI 209.7 MB disk1s1

2: Apple_APFS Container disk2 3.0 TB disk1s2

/dev/disk2 (synthesized):


0: APFS Container Scheme - +3.1 TB disk2

                             Physical Stores disk0s2, disk1s2

1: APFS Volume Macintosh HD 2.0 TB disk2s1

2: APFS Volume Preboot 48.0 MB disk2s2

3: APFS Volume Recovery 512.8 MB disk2s3

4: APFS Volume VM 20.5 KB disk2s4

[Memory-Alpha:~] djh% diskutil cs list

No CoreStorage logical volume groups found

[Memory-Alpha:~] djh%

Bootcamp Assistant can’t make the partition. It says run Disk First Aid, which I’ve done multiple times, but Bootcamp Assistant still can’t make the partition. Booted into Recovery, ran Disk First Aid, found no problems. Tried to make a MS-DOS or an exFAT partition using Disk Utility but it also errors out. What next step do you advise?

What was the error message? I have seen where there are a lot of Time Machine snapshots that prevent a new partition being created. See this article:


Erased and formatted Macintosh HD as AFPS. Put everything back from a backup. Tried to partition with Bootcamp Assistant, but failed. It said run First Aid from Disk Utility. There was an error that prevented space verification. See below.

The image didn’t get posted. can you try again?


Erased the Macintosh HD and formatted as HFS. I could then make the Bootcamp partition ExFAT. Then erased the Macintosh HD volume as APFS. MAde the mistake of making it security and case-sensitive, so will have to redo as just APFS and reinstall all my files. Will try to restore Winclone to the Bootcamp. partition after that.

After making the Bootcamp partition, just put the image back. Had to get Winclone 7, but it worked.

1 Like