BootCamp partion with many bad sectors on internal SSD

New MacBook Pro 16" 2019 with 2 TB SSD, 300 GB for Bootcamp, Winclone Standard version 8.2.

After restoring a Winclone image of my BootCamp partition, Windows 10 complained about low disk space because there was an unusually high number of sectors on the SSD marked as bad. Running chkdsk /r turned even more available space into bad sectors.

So, I decided to re-format the BootCamp partition in a Windows 10 recovery console. At first, “chkdsk /f” did not report any errors. But running “chkdsk /r” converted ALL sectors of the entire partion into bad sectors, reporting 0 KB available.

I suspect that this issue is caused by the Apple SSD driver. I’m using BooCamp version 6.1.7748 with the AppleSSD.sys driver version 6.1.7400.3 (03/19/2019).

Do you have a solution for this issue?

I have not heard of this issue before especially chkdsk marking all sectors as bad. Are you able to reformat it and does it show free space?


Yes, as I wrote before, I did format the BootCamp partition, and it looked fine, at first. “chkdsk /f” did not report any errors and the whole disk space was available. But after running “chkdsk /r”, ALL sectors of the partion were marked as bad sectors, and 0 KB was available. Since macOS is running just fine, I doubt that the SSD is defective. This only occurs in Windows, which is why I assume that there is something wrong with the AppleSSD.sys driver. Anyway, I could be wrong.

At least one person has experienced this issue before in this post:

I’m curious if anybody has experienced anything similar or even found a solution for this issue? If this is neither caused by Winclone, nor the AppleSSD.sys driver, then it is entirely possible that my MacBook has a hardware defect - either the SSD controller on the T2 chip or the SSD itself.

Have you checked the SMART data? Download the trial version of DriveDx and see what it has to say.

@ Mac_Doktor
DriveDx reports:
“Advanced S.M.A.R.T. Status: OK, 0 issues found”
“Overall Health Rating: GOOD, 100%”
“SSD Lifetime Left Indicator: GOOD, 100%”

Therefore, I doubt that this is a hardware issue. Since the restored Winclone image partition already contained a huge amount of bad sectors, one possibility is that Winclone has an issue with the new SSD controller, which is part of the new T2 chip. Or this is an issue with the WIndows driver supplied by Apple (AppleSSD.sys, version 6.1.7400.3, 03/19/2019).

Does anybody else experience this issue on their new MacBook Pro 16’’? Any ideas how to fix this?

Sadly, as this thread is about a year old with no new posts, no one may see this reply…

I am having the EXACT same issue as the OP here in July of 2021 it would seem.

2019 16" MacBook Pro - Catalina - 10.15.7 fully updated.

Boot Camp Assistant install of Windows 10 Home (21H1).

I run chkdsk /b before cloning as Two Canoes suggests. It seems to complete?? (hard to tell now that it just updates a single line of text at the bottom of the screen now). However, when it goes to restart it ends up in either a black screen that goes nowhere even after sitting for 20 minutes or to a BSOD with the error message:

“Your device ran into a problem and needs to restart. We’re collecting some error info, and then we’ll restart for you. Stop side: BAD_SYSTEM_CONFIG_INFO”

Also noticed I can do a fresh BCA install, run chkdsk (without /b) and it reports no errors, clone the BOOTCAMP partition, restore that same clone back to a fresh partition and run chkdsk (without /b) again and get the following error:

“The master file table’s (MFT) BITMAP attribute is incorrect. The Volume Bitmap is incorrect. Windows has checked the file system and found problems. Please run chkdsk /scan to find the problems and queue them for repair.”

To make an even longer story shorter. I ended up trying to run chkdsk /r and I ALSO found that the majority of the sectors were marked as bad sectors.

A quick look in Disk Utility a showed a 100GB BOOTCAMP partition was now filled with 90+ GB of data with just Windows 10 installed.

I erased the internal drive and cloned back a copy of Catalina and Disk Utility showed all was good and TechTool Pro 13 showed no errors in Surface Scan - SMART Check - Partition Map - Volume Structures.

So… I think it is safe to say this NOT an SSD hardware issue. Have no reason to think it is a WinClone issue.

Looking a lot like it is an issue with the current Apple SSD driver not playing well with Windows 10???

I find it hard to believe that only two people have experienced this???

If Markoto (OP) is still around, I’d love to hear if you found a solution???

I guess I am going to have to settle with running Windows 10 in VMware Fusion…



Yepp, I am still around :wink:

I came to the same conclusion that “chkdsk /r” (repair defective sectors) does not play well with the Apple SSD driver. However, “chkdsk /f” (repair errors) seems to be fine. My “solution” was to stay away from “chkdsk /r” after restoring my Bootcamp partition.

The only way that I found to fix my Bootcamp partition and get rid of the bad sectors was this:

  1. Create a Winclone image in file mode (WIM based image), not in block based mode (!).

  2. Format the Bootcamp partition.

  3. Restore the Winclone WIM image.

As far as I remember, the block based Winclone image did retain the bad sectors, but the file based Winclone image did not.

I hope that this helps. Good luck!

Hey :slightly_smiling_face:

Good to know you are still around and thanks for the reply…

Yea, turns out that using chkdsk /b actually includes “the functionality of /r” according to Microsoft. My exploration running chkdsk /b shows inconsistent results that does indeed sometimes result in a LOT of “sectors” marked as bad. Internet research seems to indicate that using the /r parameter on an SSD is not only unnecessary (because the SSD controller handles a similar function of marking bad “sectors”), but there are a number of reports of “many sectors marked bad by chkdsk /r” found online.

Actually, in my case I am getting a chkdsk error on a fresh BCA install of Windows 10 (21H1) before I even get to running Winclone. Two Canoes directs us to run chkdsk /b prior to cloning a BOOTCAMP volume.

I can run chkdsk (no parameters) a dozen times and get no errors. We know running chkdsk /b will cause an error. Even if I just run chkdsk /f as a precaution before cloning, chkdsk /f appears CREATE an MFT BITMAB error when it is run that I have not been able to clear since… Once I run chkdsk /f, chkdsk will report the error every time, and chkdsk /scan reports no errors every time.

Anyway, I do not want to hijack this thread. I just find it interesting that no one from Two Canoes has chimed in as it is their suggestion to run chkdsk /b and that others have not run into issues running chkdsk prior to cloning. Perhaps no one bothers to run chkdsk??

Thanks again for your reply, it pointed me in a slightly different direction…