BOOTMGR is compressed

Is anyone else getting the “BOOTMGR is compressed. Press CTRL ALT DELETE to restart.” at startup?

When do you get this message? Can you give a bit more info on what version of Winclone, version of Windows, and the mac you are using?


I am on a Mac mini. I use boot camp for windows 7 pro, and parallels sometimes. I have resolved it by booting from the Win7 DVD and repairing startup disk.

(I had tried to save space last year by changing the c: drive preference in Win7 to “compress to save space”)

1 Like

I am having the same error message: “BOOTMGR is compressed. Press CTRL ALT DELETE to restart.” at startup after performing a Save and Restore with Winclone 6.1.5. I am using a Mac Mini (Late 2014), Windows 7 and Mac OS X 10.10.2. Pressing control-alt-delete does nothing.

raytibbitts says he booted from a Win7 DVD. How do you do that on a Mac Mini? I have the DVD and a optical drive but the DVD does not show as a boot option under Startup Disk system pref or the boot picker.

Try switching between Legacy and EFI and see if that resolves the issue. It re-writes the startup files.


I am having same problem on a MacBook Air upgraded to High Sierra. Using the change to EFI leaves WinClone without progress “Copying EFI Boot Files”.

Made a more complete post of process.


@tperfitt just FYI you keep offering the same solution to the problem which has repeatedly been reported not to fix the problem. I have figured out the problem and the solution. Please include this information in your future replies to people as it worked for me.


Since this error is often caused by a compressed hard drive, it is possible to fix it by disabling data compression. Here are the steps to uncheck the “Compress this drive to save space” option that’s currently applied to the hard disk.

  1.  Boot from a Windows installation DVD (in my case Windows 7).  Let it load. Choose your language.
  2. Click on "Repair your computer" in the bottom left corner of the window (DO NOT choose "Install Now")
  3. Next select your Operating System in the list.  DO NOT click "Next".  Instead click the "Load Drivers" button
  4. Click on "Load Drivers" button
  5. A pop up will open to select a driver.  Instead use that windows to browse to the boot drive, C: (in my case here)
  6. Right click on the C: Drive and select "Properties" in the context menu.
  7. Go to "General" tab
  8. *UNCHECK* this option: "Compress this drive to save disk space" and hit "Apply" button
  9. You'll get a confirmation window pop up.  Make sure "Apply changes to Drive .... subfolders and files" is checked off on this window and click "OK".  

10 . WAIT. Be Patient. If you try and reboot now the decompression will be interrupted and not complete. Once the window you have open starts responding again you can OK out of things and close out of the Recovery Console as the compression process completed.
11. Restart your computer and enjoy your Bootcamp partition

This is what worked for me to fix the issue. It seems to be caused by compression of the OS by the Winclone service when making a backup and it doesn’t properly un-compress the files when restoring the backup so I had to do it manually using this method.

Please fix this. Thank you.

Thanks for the information. It sounds like it is an issue with people that have turned on file compression but the boot loader doesn’t recognize it. I’ll try to replicate it in house by turning on compression, creating then restoring a winclone image.

again, thanks for posting the fix.

Not sure this is the fix either if one is using a Windows 10 disc. I appreciate the details from Flux, but Windows 10 doesn’t allow for any navigation to the C drive in order to deselect compression.

The question I have is why would be be compressed in the first place? Is this something Winclone 7 selected in in order to keep the file smaller?

Currently hoping that simple reinstall to the restored image will work, but no luck yet.

Any idea if there is a fix other than the one suggested above?

My situation: Winclone 7 on MacBook Pro 2011 17" that had a Windows 10 Pro installation in Bootcamp (upgraded from original Windows 8 Bootcamp install). After attempting to restore the image, I get the Bootmgr is compressed message. I have attempted the fix suggested by Flux, but some of those suggested steps/options don’t exist on a Windows 8 or even 10 installation DVD. At this point, until this is figured out from the developer standpoint, I’m now locked out of my Bootcamp partition. Also, I’m not sure when and where I would have ever selected disk compression.

Thanks for posting this. Bottom line is I was trying to manage this with the trackpad on a MacBook Pro, however, the contextual menu (2 finger or right click option) is not available on a trackpad when booting from a Windows disc. Bought a cheap 2 button mouse and was able disable Disk Compression and everything booted fine. So, if anyone is trying to get this done, follow the instructions by Flux (thanks for the detail) and make sure you have a 2 button mouse around to plug in to get you to the Properties of the C: drive to disable disk compression.

1 Like