Cannot boot after migrating to new Mac


I bought standard version recently and tried to migrate Windows 10 from Macbook Air late 2014 to Macbook Pro Late 2016.

After restored image to Macbook, when booting windows, it shows ‘INACCESSIBLE BOOT DEVICE’.

I then tried many times with different settings, such as not updating BCD, the result is the same.

Any ideas on how to solve this issue?

That message means that it is booting via “legacy” boot mode, which shouldn’t be the case for Windows 10 on that machine. Try setting to EFI mode manually in Winclone 6:

I have also seen instances where EFI mode can’t be selected until you reset the PRAM (which is surprising, I know).


I tried to set EFI mode manually while the result is the same.

In fact, I also tried to make a clean install of windows 10 on the new Mac, backup, then restore on the same mac, it boot successfully without any problem.

When comparing this 2 cases, I notice that the name of the restored partition name is empty (showing “–” in Disk Utility) for the original image from Macbook Air, while the name of the restored partition is preserved (restored to “BOOTCAMP”) for the image clone from a clean install.

Could it be the reason that causing the boot issue?

Just add a side note here: I was backing up the windows to the SD Card Slot in Macbook Air, perhaps it cause the drive name empty? I haven’t try to backup it using a usb card reader.

Also, when restoring the same image inside Macbook Air, I can boot windows successfully.

I suspect this is related to the potential different physical block size between the two machines. Can you try creating an image with “WIM” mode (in the preferences) and then try restoring that image to the late 2016 mac?

More info here:

I think the image is already in “WIM” format as I haven’t check the option to enable Block Size Mode.

I have totally the same issue I’m fighting for the last day. Is there any solution for that?

Can you try restoring with the most recent beta ( ) and see if that helps?


Did not help… Resolved by re-installing from scratch. Please refund me my 20$, because WinClone program does not work.

Do I have to install beta on both old mac and new mac to try?
Can I have the backup image from old mac and use new mac on beta?

Well, I have tried that. It just does not work. Thus far I would like to get my money back

Head on over to to submit a refund request and I’ll get it processed ASAP.


1 Like

I started typing in my question, and the assistant figured out that this question was similar to mine. It may as well be the same. I have been trying now since the end of July when I got my new MacBook Pro to transfer over Boot Camp from my 2008 Mac Pro and nothing is working. Even though Boot Camp on my desktop takes up 33 GB of an 80 GB partition, when I winclone it, it is only 8.4 GB. And then, when I migrated to my MacBook Pro, it will boot up. Is there a step-by-step guide for doing this? I have followed everything I have found on the website. This is getting really discouraging because I just upgraded Winclone to be able to do this

Winclone will help move the data and make it bootable, but the drivers are related to Apple Boot Camp drivers and what Windows supports. It definitely sounds related to this.


I have also the same issue.

I bought Winclone standard version (6.1.9, 17572) recently and tried to migrate Windows 8.1 from Macbook Pro 2015 to Macbook Pro 2017.
(BootCamp 100GB, same size)

After restored Winclone image to new Macbook, when booting windows, it showed the blue screen with the ‘INACCESSIBLE_BOOT_DEVICE: Your PC ran into a problem and needs to restart.’ message.

I tried many times and also tried to switch EFI mode manually.
However the result was the same.

Is there any other solution to solve this issue?

Did you do a disk to disk clone? if so, try saving the image and restoring the image the new Mac. Also, makes you are using WIM (file based) imaging rather than block based. These are set in the preferences.


I didn’t doing a disk to disk clone.
I tried saving the image of BOOTCAMP on old Mac and copying the image to new Mac.
Then I restored the Winclone image to new Mac.
But Windows (the BootCamp image) failed to boot.

And I did not use Block-based imaging.
I used WIM imaging (default setting in the preferences).

Is there any other recommendation?

28 PM

Can you look inside the image and see if there is a Windows.wim or a boot.img.gz? Control-click on the image and then select Show Package Contents to see inside the image in the Finder.


Yes, there is a Windows.wim.

Then what should I do?

So it definitely a WIM-based image since it has the Windows.wim file. I assume that all files are visible on the bootcamp partition in macOS after restore, and that it just will not boot. If you have an older Mac (2014 or earlier), it will most likely boot in legacy only. If it is Windows 7 or earlier, it won’t run on the more recent Macs (generally 2018 or later).