Cannot boot Catalina from external SSD

I have one Catalina on an iMac 2019, with Boot Runner installed, and another Catalina on a Samsung T7 SSD external drive. I can get Boot Runner to only recognise both of them but when I select the volume on the T7, it only boots back to the volume on iMac not on T7. Please help.

“Blessing” the volume on extern SSD does work. It is just the same as selecting the external SSD as the startup disk which defeats the purpose of having Boot Runner.

The actual bless command that Boot Runner uses when selecting the volume is shown in the log:

(see https://twocanoes.com/knowledge-base/boot-runner-3-setup-guide/ )

Logging Options

Boot Runner logs messages via the Apple System Logger. To view the logs, open Terminal and enter in the following command:

log show --style syslog --predicate ‘process contains[cd] “Boot Runner”’ --info --last 2d

You can adjust the “2d” for a longer or shorter time period. You can specify a number and then m (minutes) h(hours) or d (days). For example: “–last 2m” or “–last 3h”.

To send the output to a file, redirect the output:

log show --style syslog --predicate ‘process contains[cd] “Boot Runner”’ --info --last 2d > ~/Desktop/bootrunner.log

This will save the last 2 days of Boot Runner output to a file on the current user’s desktop called “bootrunner.log”.

tim

Thanks. Should I add

| grep bless

at the end of the log command?

And then what should I do with the log?

I check and find no blessing, it seems.

Should I send the log and submit a support ticket instead? Thank you.

So, that’s it? No solution? I just go back and use “Startup Disk” then?

Where should I send the log to, please?

Thank you.

I have the log and i responded from our support system.

tim

Thank you very much for your kind help. I have sent another log. Please kindly indicate what I should do, so that the log can help with the problem.

I responded in our support but I’d like to add the solution here:

It appears that macOS is not allow the external drive to be selected due to security protections. To allow it:

  1. Open System Preferences and select Security & Privacy
  2. Add /Library/PrivilegedHelperTools/Boot Runner.app to Full Disk Access.

That seems to resolve the issue.

Thank you. But after upgrading to version 3.4, I select the SSD to boot, and then I am stuck to the “Rebooting” screen. So I guess I cannot be sure if the solution works for now.

We are still working on this. It will happen :slight_smile:

tim