Cannot restore after update to Mojave


I’m out of options, so seeking a bit of help…
Here’s what happened:
I decided to update my MacBook 12, running High Sierra, to Mojave. Until then I had a perfectly functioning dual boot using bootcamp W10.
The update to Mojave went fine, no hiccups, no surprises, the thing booted back into Mac OS perfectly, nothing was touched or out of place. Just the new OS running.
Prior to doing that, I did make a clone using Winclone of the bootcamp partition. You never know…

Next thing you know, I’m trying to boot into Windows, which immediately BSODs and tells me an unexpected error has happened (you don’t say). error code 0xc0000098.
Okay… I’m naively thinking, that’s fine, I’ll just restore the clone I just made. I do that, BSOD, same error.
Switching to and fro EFI/Legacy doesn’t solve anything, resetting NVRAM doesn’t make a difference.
Even trying to import the restored bootcamp clone into Parallels is failing.

I did succeed in creating a workable W10 bootcamp from scratch, and it’s booting into it, but it doesn’t help me restoring the setup I had.

What do I do now?
Thanks for any help.

P.S.: Silly question: I managed to restore the clone to a disk image. I also have access to the bootcamp NTFS partition from Mojave. So what if I just mount the image in Mojave, and copy all its content to the new, working W10 partition? Could that work?

Looks like the 0xc0000098 is a BCD error, so the partition table somehow got changed. After you restore, try “Make EFI Bootable…” in the tool menu and select the boot camp partition.


Thanks, but I already tried that.
“Switching to and fro EFI/Legacy doesn’t solve anything, resetting NVRAM doesn’t make a difference.”

Update: had an older (1 year) backup of the bootcamp partition made with Winclone…6. And guess what, this one restored perfectly.
The one that failed was made with Winclone 7, which certainly points to a Winclone failure to back up properly. Just saying.
Winclone 7 did restore the 6.x version properly, though.