Can't do incremental backups

I’m new to Bootcamp and Winclone but a long time Mac user. I have a Mac Pro 4.1 (flashed to 5.1) running Mojave 10.14.6 using an RX580. I installed Windows 10 on a new separate SATA SSD drive in one of the drive bays (Legacy boot mode) - my MacOS install is on a separate SATA SSD in another drive bay.

After doing all the updates and installing the iMac Pro bootcamp drivers with Brigadier I can boot between them using startup disk in system preference and the bootcamp control panel.

I installed Winclone and clicked “create image from volume” but it complained about no licence so given the black Friday sale I just went ahead and took a risk and purchased one. I created an image of my bootcamp SSD to a file on an internal hard disk. This took several hours and the progress bar didn’t move much until near the end but the log file allowed me to see it was still going.

Although I haven’t tested a restore the image was created successfully. I then configured the incremental settings but can’t get this to work. I’ve booted back and forth between MacOS and Windows over a few days so was trying to run this manually. The menu bar say in red “Backup destination missing” but going into configure it is listed next to “select destination” and clicking a re-adding makes no difference.

Next to Source Boot Camp Partition clicking the “connect” button shows a pop up with my “System Reserved” and “BOOTCAMP” volumes (both created by the Windows installer and both visible in the Finder). If I try to reselect “BOOTCAMP” I get an error: Cannot update image with volume ID - the associated Windows volume ID could not be updated in the image at /Volumes/Media 3/Win 10 Pro Clone.winclone. Please check permissions and try again."

I have now tried making a new image from volume replacing the old one and still get the same.

There is nothing in the log beyond the licence and diskutil list to give me any hints. If I turn off the incremental menu in the preferences quit, relaunch and turn it on again the red error test disappears but when turning to manually update incrementally the error message appears “No Backup Destination. The Boot Camp partition associated with this image cannot be found. Please mount or attach the correct volume and try again.”

I really wanted Winclone for this incremental feature and the chance to restore Windows without all the hassle of installing fresh (I can make a straight copy of the data with disk utility or backup from inside Windows) so hope you have ideas as to a solution.

So I tried waiting until the schedule tried to update the image and still get the same errors.

What permissions should I see in the Finder for the drives and the image file?

There is not special permissions, but the Winclone menu needs to be able to write to the location. Please try opening the same location where the image is located and try create a new folder or file and see you can do that successfully.

tim

I tried a new folder and moving the image there but no change. Winclone can see the image file but complains about the Boot Camp Partition not being found yet it is there in the Finder and can be seen on hitting the connect button:

Screenshot 2019-12-11 at 20.15.30

but when selecting it I get:

Screenshot 2019-12-11 at 20.18.56

As mentioned before there is no problem creating a completely new image - just trying to update one.

Ah, I might know what it is. Is it a block based or WIM based image? It has to be a WIM based image to do incremental. If you control click on the image in the Finder and select Show Package Contents, if it has boot.img.gz then it is block based. If it has Windows.wim in it, then it is WIM based.

tim

Hi Tim

It is WIM based:

The volume ID is stored in the productInfo.plist inside the image. Try selecting that file and doing a File->duplicate in the Finder and see if stuff can up written inside that image bundle.

tim

Yes I can Duplicate that file inside the bundle OK.

What is strange to me is that if it was a permissions issue at the source or destination you would think the initial image creation would fail. It is as though once created the permissions are changed or the incremental updater process is somehow running with different ones?

I looked at the code, it what causes that error is when the mediaUUID entry in productInfo.plist is changed and then saved. Specifically, Winclone does this:

  1. Reads in the productInfo.plist file.
  2. Changes the mediaUUID value in memory.
  3. Deletes the productInfo.plist
  4. Saves a productInfo.plist.

If the read/save/delete operations fail, then you’ll get that error message.

tim

OK I wonder how the UUID is changing?
…or what to try next? I’m not sure if we are talking about the one for the Windows SSD or the hard disk with my Winclone image file?

I thought a UUID was set when formatting a drive? What I did was make a new image of my Windows SSD and then try to update it.

The UUID is the partition UUID. I wonder if the Boot Camp drive is on a non-GPT disk. That may cause this. Open up Disk Utility and see if the drive that the boot camp partition is on is GPT.

tim

Yes it does says in disk utility that the main volume (that has both Bootcamp and System reserved partitions) is Master Boot Record.

Not sure if that is the default when installing from the old iso CD of Windows 10 I used that was made a year or two back or because I originally checked the disk was recognised in MacOS before booting from the CD and running the Windows installer. I know I need to run Windows in Legacy boot on this machine to avoid issues so whether that would prevent GPT?

If this is the issue and I won’t be able to do incremental updates what are my options? It took many hours to get Windows, updates, drivers and games installed so hopefully not back to square one…

If you used Boot Camp Assistant, it makes sure the disk a GPT prior to creating the boot camp partition. If you used the Windows installer, then it is fine with a MBR disk partitioning scheme.

There is not technical reason that it couldn’t work but Winclone uses the GUID that is only available on GPT disks. I’d have to make a change in how Winclone operates to support non-GPT disks. I’ll add it to the list of feature requests.

if you want a refund, go to https://twocanoes.com/order-assistance-and-feedback/

tim

Hi Tim

Thanks for the reply.

FYI Bootcamp assistant doesn’t actually run anymore on old Mac Pro models (2009 to 2012) once you move to Mojave. It was disabled along with Filevault as you need a metal capable GPU for the upgrade and most of these are non-EFI so you loose the boot screen. Apple also never updated the bootcamp drivers for Windows 10 so you simply have to make and boot from a Windows installer DVD, let Windows update all the drivers. and then you can then download the iMac Pro Bootcamp drivers which give you the bootcamp control panel version needed that can see the APFS formatted MacOS SSD to switch back.

I actually wanted to keep Windows completely separate from MacOS anyway just in case I ran into issues so purchased a separate SSD for it.

If you think the incremental update feature of Winclone can be made to work with MBR as well then I’ll just leave the disk as it is (the Windows install is working well so far) and just wait (assuming we are talking months not years?).

It is obviously just a bit frustrating creating a new complete image each time because it takes a long time…

I’m not sure should I encounter a Windows problem and need to restore the image file I’m saving if the drive will be made MBR again from this (assuming the SSD was formatted as GPT in MacOS first before the restore) or if it would maybe refuse to restore to it because of the difference?

Hi Tim - Happy New Year & hope you got a break over the holidays. Just wondered if you have any advise about my last question and if there is any news about a rough timeline for MBR support as it seems necessary on these older Macs.