Can't get restored BOOTCAMP to boot

I’m using Winclone 8 Basic. My old 2010 MacBook Pro died but was able to get the drive out of it (which works externally). Bought a new 2019 MacBook Pro. I tried to use volume to volume copy but it complained that the blocking was different so I just ran a copy to a winclone file on the new machine from the external drive (which had not been SYSPREPed obviously!) Then I used DiskUtil to create a BOOTCAMP partition and restored to that partition from the Wincloned file. I also turned off Secure Boot on the new Mac and allowed external boots. When I try to boot the Windows partition I get the Windows logo and spinning circle of dots, then it says “Your PC ran into a problem and needs to be restarted. We’ll restart it for you.” This repeats a couple of times and then it shuts down. No other error message or code provided.

I presume Microsoft still thinks the license belongs to to the old 2010 machine (I didn’t deactivate it or anything). Should I have? Or is this problem because there wasn’t a SYSPREP between the 2010 MBP and the 2019 MBP? Or is it something else entirely.


P.S. The BOOTCAMP volume does mount and show up in finder.
P.P.S. The new machine is a 15" MBP, 2019 running Mojave. (Not a 16") Do I need to inject SSD drivers on this machine?

PPPS: I tried using VMWARE to boot from the bootcamp partition but got the same result - Your PC ran into a problem…" etc.

I follwed the driver injection instructions (it took way more than a “minute” for the keyboard to wake up), the injection script ran to completion, and booted the BOOTCAMP partition again. It did the same thing (Your PC ran into a problem) but this time there was a Stop Code: Unmountable boot volume

This is what it looks like in DiskUtil - it’s called Windows 7 because originally I was on Win 7 and got the free upgrade to Win 10.

I wonder if the issue is related to older hardware and the Windows 7 upgrade to Windows 10. I am surprised that VMWare fusion does not boot it which makes me think that all the data was not completely restored.


I wish there was a way to use Winclone to restore only the Applications and user data (and not the Windows OS and boot stuff). I would have been happy to use Bootcamp assistant to set up a fresh Windows partition if I could have got the installed apps ported into it with Winclone.

At this point I will probably have to delete the partition and use bootcamp assistant and manually reinstall everything.