Can't migrate Windows on the same Mac

Hi. I have a problem moving a bootcamp partition on external ssd on iMac.
First I tried moving my exiting bootcamp partition on external drive using volume to volume cloning, but it stuck on “identifying source”. Then I created an image and restored it to desired drive, all went well, no errors occurred. After deleting old bootcamp partition from internal drive and restarting to bootcamp I got a blue screen saying something like “there is a problem starting windows” and an QR code which lead to automatic restart. I tried switching between EFI and Legacy boot - no luck.
After all that I decided to make a fresh windows install and cloning it. Installed windows and support software, connected external ssd and formatted it to NTSF, restarted back to Mac OS, repeated the steps above. This time volume to volume cloning worked well, still it won’t boot… After restarting with opt key it shows EFI Boot instead of Windows and shows blank black screen on boot for about 30 seconds, than shut down. Partition type is set to GUID / GPT. What am I doing wrong?
iMac (Retina 5K, 27-inch, 2017), Mac OS 10.13.5 (17F77), Samsung T5 500Gb SSD, Windows 10 Home x64 (ISO from Microsoft website), Winclone 7.1.

upd. I tried again… Disabled the SIP, formatted the disk to FAT (GUID) and restored from the previously created fresh Windows image - same blue screen as the first attempt (INACCESSIBLE_BOOT_DEVICE).
For now on I gave up, hope for the response.

1 Like

The INACCESSIBLE_BOOT_DEVICE is related to the new drive / computer having different hardware that prevents it from booting up. It also could be related to Windows 10 Home edition, which may not support external booting.


Hopefully not interrupting this conversation - but in the interest of not spawning too many categories:

I am trying to migrate an existing Win 10 Professional Bootcamp partition from old Mac (MacBook Pro 13" Retina, 2013) to new Mac (MacBook 12" Retina, 2015). I create the Bootcamp image using Winclone 7, create new exFat partition on new Mac, restore image to that partition. All good.

New Bootcamp partition starts to boot but fails with INACCESSIBLE_BOOT_DEVICE stop.

Tried recreating the Bootcamp image after trying the regedit fix setting the BOOT_FLAGS to 0x14. Same problem.

To be honest, I have never ever been successful in using Winclone to create then restore a Bootcamp partition. The restored Bootcamp partition always fails to boot because of the INACCESSIBLE_BOOT_DEVICE problem.



When you download the drivers for Boot Camp for the 2015 MacBook, does it have the AppleSSD driver in it? If so, that is required to boot and needs to be installed prior to booting. You can do that in a VM or by injecting the driver in the WIM image. See


Thanks for the reply. Managed to boot it after running sysprep prior to migrating on the external drive. All works perfectly fine, much faster than on internal apple drive.
However, the EFI Boot shows instead of Windows during the boot device select on restart, is it normal?

The Bootcamp drivers when downloaded for the new hardware (2015 MacBook) do include the AppleSSD driver (as I believe the block size is now 4K for the newer SSDs). I’m sure you’re right, that driver is needed to boot.

I’ve tried the dism install method as listed here:, but it’s failing at the dism /Mount-Wim step - the mount process stalls at 1% complete (I’ve watched it stuck there for an hour, no activity at all visible in task manager). The only difference is my USB drive is exFAT formatted, not FAT as the article says, but I’m doubting that’s an issue.

Going to explore other ways of getting the newer driver installed before creating the image (on the older hardware), so that it’s there when restored onto the new hardware. Will update - if you have any other suggestions, always welcome.


Thanks for letting us know.