Can't restore to new Touch Bar MBP. How to Shift-F10?

I’ve got a new MBP (Intel, with Touch Bar) and want to migrate my previous BC installation onto it. Following the excellent instructions at I’m stuck at “Injecting Drivers” step 13: “Press shift-F10 to open a DOS command prompt. You may have to wait a minute for the TouchBar, keyboard, and mouse to start working. …”

Nothing happened. How do I invoke Shift-F10 if my touch bar never energizes? AFAIK the migration was successful otherwise.

Answering my own question: I followed the wrong tutorial. I should have followed this:

However, when the time came to execute the script from the DOS command line, the batch/script file winclonefix.bat contains the line

dism /Image:D:\ /Add-Driver /driver:c:\AppleDrivers /recurse

Somehow my Windows installation was instead on drive F, and I got a drive-not-ready error and the script didn’t execute. So I simply typed the command at the DOS prompt, replacing the “…Image:D…” with “…Image:F…” and it worked.

Another thing: the Windows 10 ISO I used was too big to copy the BootCamp directory onto the same flash drive. I had to do the BootCamp reinstall from another drive.

…but of course I couldn’t install BootCamp because I got a BootCampService.exe error. Following the tip in I was able to force-uninstall and then reinstall BootCamp.

How did you get the touch bar to fire up? I am having no luck. I am using WinClone 9

I have been poking at this for a few days now and I finally figured out part of the problem. The document referenced approve has the autorun.ini and the autounattend.xml in the apple driver folder but, they need to be in the root of the jump drive. Making this change I was finally able to get the touch bar to work.

Ow when I run the c:\winclonefix.bat file I get an error 21 code

I tried making the changes from D: to F: in the winclonefix.bat file but I still get the same error. I doubled check that on the macbook pro there is a bootcamp drive with the winclode content from the old there.

Any further thoughts on what to try next?

I think I responded to this in another thread. Try seeing if d: or f: is mounted:

dir f:\

You may have to use drvload to load the driver.