Clone from internal to external SSD won't boot

Tim (I assume) –

Hope all is well and that you and yours are all safe and healthy.

  1. I’m using a 2018 MacBook Pro, and it’s 500G internal SSD has a 100G Bootcamp partition with Windows10 happily running when needed.

  2. I’d like to reclaim that 100G on the MacBook, and I’ve got a portable case with a 1T Samsung PRO850 drive that’s not being used very often. The drive has previously been used as a spare/transfer drive, and it originally had a 800G APFS volume and a 200G Bootcamp NTFS partition with my older Windows 7 system on it.

  3. I upgraded to WinClone8 a couple of days ago with the intent to create a clone of my internal Win10 partition on the portable SSD. When I attempted to create the portable clone I received the “dissimilar block size” warning, and I’ve been trying to “save the Win10 image and restore it” as WinClone8 instructed me to do.

  4. All seems to go well, but the Win10 clone appears to go halfway through booting before it crashes and restarts the MacOS (Mojave) native to the MacBook. I’ve tried repeating the entire process (including deleting/restoring the Bootcamp partition on the portable drive) with no success.

I originally had wanted to preserve the existing Mac partition on the portable drive, but I’ve now decided that it’s contents are no longer needed so I can do anything to the portable drive I need to in order to get the process to work. My end goal is to have a 200G Win10 Bootcamp partition on the portable, with the remaining 800G used for Mac. I’ve watched the YouTube vids for WinClone8, but I’m still unable to make it work.

FWIW, I’ve noticed that the process of restoring the WinClone8 image to the portable Bootcamp partition changes the name I gave the drive partition (it subsequently shows up on the desktop and in Disk Utility as BOOTCAMP, and shows up during the “hold option” MacBook boot process as “EFI BOOT”) and converts the partition from ExFAT to NTFS.

I’d appreciate any help/insight you can provide.

Best Regards,

Bruce

1 Like

External drive booting can be tricky, but it does work for a lot of cases (at least the ones we have tested). It seems like you are doing everything correctly but Windows is loading a driver that is causing a panic during boot. Do you see any error messages? Safe mode and finding and looking at the boot log may be helpful (though I have had only partial luck with that method).

tim

Thanks, Tim —

Hope you had a great Easter weekend, such as it is. I certainly appreciate you getting back to me so soon.

Q1: if there’s some type of “block mismatch” between my internal SSD and the portable (which I can easily reformat) is there a way to correct the block size issue to permit a “clone” process (instead of image/restore)?

Q2: I did not remember to “prep” WIN10 before creating the image file. Is this something I need to correct, and if so where can I find the instructions for same?

Best Regards Always,

Bruce

<><><><><><><><><><><><>

Bruce Coffman, LEED AP

touch thirty three, inc.

713/775-0714 cell

<><><><><><><><><><><><>

You can try “prepping” it with SysPrep, though I have not had lots of luck with that for external drives:

https://twocanoes.com/knowledge-base/Tips-for-Preparing-a-Boot-Camp-Migration/

tim

Thx as always, Tim — I appreciate your continued support.

Searching the InterWebs led me to this:

https://youtu.be/910Y1hLreRc

which appears to be a well-structured (and supported, comment-wise) method for installing/running WIN10 on an external SSD. Not sure if I can find a way to adapt it to work with Winclone image/restore. Any thoughts?

Here is what I found works:

You need to do two registry edits using RegEdit, before you clone (or via Parallels if you have the external drive)

Under HKEY_LOCAL_MACHINE\SYSTEM\:

  1. Under HardwareConfig Click on entry with a bunch of numbers (Its a UUID) and change BootDriverFlags to 14 in hexadecimal.
  2. Under MountedDevices delete all entries, then delete MountedDevices complete.

I did both and this worked great for me.

1 Like

I’m happy to know this worked for you, but your instructions are like a foreign language to me. I’m not following if what you recommend is done in Windows or Mac, where these registers To be edited are located, nor even what 14 in hexadecimal is.

Any clarification anyone can provide would be helpful, as might be a thumbnail explanation of what this process is doing and/or any danger(s) lurking within.

Thx!

I agree that if you are not comfortable editing the registry, you should definitely not edit it.

tim