Cloning BootCamp to external SSD Drive

Hello, I am currently having issues booting into Windows on the External SSD Drive. I used Winclone to clone the Bootcamp partition, then restored the image to the external SSD, injected the Apple SSD Driver. Restarting computer, I boot into windows, the windows logo comes up begins to load then Blue screen, Inaccessible_boot_device. I have restarted computer numerous times with the same results, I have added make EFI bootable, no luck, same scenario, tried legacy but that just states no bootable drive detected.

Any suggestions on what to do please. I need to get back into my windows ASAP for work.
I have a 27 inch iMac Late 2013 with Internal SSD (which works fine for the Mac OS) I am on Mac OS Catalina 10.15.5

Original bootcamp partition was part of the local (internal HD) partition. I upgraded the internal drive to an SSD Drive.

Please HELP

Here is what I found after MUCH work.

You need to do two registry edits using RegEdit, before you clone (or via Parallels if you have the external drive)

Under HKEY_LOCAL_MACHINE\SYSTEM\:

  1. Under HardwareConfig Click on entry with a bunch of numbers (Its a UUID) and change BootDriverFlags to 14 in hexadecimal.
  2. Under MountedDevices delete all entries, then delete MountedDevices complete.

I did both and this worked great for me.

Thank you @apple4ever! I had this exact same problem due to moving my bootcamp partition to an external drive and your two steps fixed the problem immediately!

Interesting. I’ll see if we can replicate it and add that as a menu command.

tim