Cloning WIndows 10 Disk to a larger one on Mac Pro 5,1

Another system, another try to clone. Winclone used to be bullet proof a few years ago. I had not used to for a while and now I am simply unsuccessful on two machines.
This one is trying to clone a BootCamp disk - single NTFS Primary on GUID disk with fake MBR, Mac Pro has to use BIOS emulation boot, For some reason cloning disk to disk ends in an error of inaccessible disk. I created an image (which took forever) and restored it to the new disk.
Failed to boot, no bootable disk found.
I rewrote the MBR loader.
Same story.
Booting into Windows on the original disk I find that it has an EFI partition of 200MB and a Primary partition. The new disk created by WinClone has a single Protective GUID partition not accessible or mountable. It shows up as Windows 10 with all its content under MacOS.
I tried a windows utility to correct that but it clobbered the disk.
I tried making the new disk just an MBR disk, but WinClone did not like that, either.
Not sure I should waste electricity cloning again.
Both disks are on the same controller. Both are Crucial.
Any ideas? I sure would hate to pay for a Windows cloning utility like Acronis.

I’m an old Mac Pro owner stuck with MBR as well. My own issue was I wanted to do incremental updates and that feature I found out after purchase only worked for GUID partition disks. There was a suggestion this might be added later but I’ve had no replies to my requests for a rough timeline and with the latest update (8.2) even my full clones are failing now. I think MBR support for these old Macs is very low priority so might never get fixed, probably should have taken the refund option at the time but I wanted to support a Mac developer and was willing to wait…

BootCamp seems to be very particular about the format. I ended up going back to an older OS to create it:

  • Partitioned and formatted in HFS+
  • Used a Lion image I had stashed with CarbonCopyCloner and restored it to that disk
  • This booted on my Mac Pro 5,1, but the BootCamp Assistant stalled during partitioning
  • I moved the disk to an older Mac Pro 2,1 I still have on my premises. BootCamp Assistant succeeded on it without trouble
  • I should note I had to create a Windows 7 installer DVD to get it to proceed
  • Moved the disk back to my 5,1 and used WInclone to restore the image.
  • Booted first on a built in SATA slot to make sure Windows configured

Now working fine with a PCIe card. Another note: I had to use Fusion v10 to create a BootCamp VM installation with the real disk, the current Fusion v11.5.5 choked on creation. The resulting VM runs fine under the current version.

It pays to keep old stuff around.

This does not look like a WinClone issue.