"Could not copy BCD to Windows partition"

Tried to use Winclone 6 to restore a Windows 10 image to a new FAT32 partition on a MacBook Pro running OS 10.12.6, after replacing the hard drive in the computer.
Winclone generated the following error:
“Could not copy BCD to Windows partition. This version of Windows may not support legacy booting”


That message is after the data restore is done, and Winclone is trying to set it as “legacy” bootable but can’t. When did you create the image in Winclone?

You can set it to be EFI booting and it should boot up:


Thank you! That got me almost all the way there. Upon switching to EFI, I am able to boot from holding option at startup and choosing “EFI Boot.” It’s still a little shaky, only able to boot in safe mode sometimes, but I think I can work through that.
Another weird issue is now I’m seeing a duplicate listing at option-boot for “Macintosh HD,” and both versions of it boot the computer in OS X normally. What’s with that?
Also, is there a way to rename the generic “EFI Boot” to “Windows” or “BOOTCAMP” (which is the actual name of the volume?

Try resetting the NVRAM and see if that helps:


NVRAM reset has no effect, seems to be stuck with double “Macintosh HD” boot options no matter what I do.
Also, having done some cmd boot repairs from a Windows 10 boot USB, I am now able to get Bootcamp running whether I set it as EFI or Legacy from Winclone, but the partition still shows as “EFI Boot” in the boot options.

However, if I set Startup Disk to BOOTCAMP from within OSX, it results in a “No Bootable Device” error, although I seem to remember this having been the case for a long time in my bootcamp usage. Any insights?

From what I have seen, if it is a 2013 - 2014 Mac that supports both Legacy and EFI booting, and you set it to EFI booting via Winclone, the drive will show up as “EFI” when holding down the option key. Selecting the drive in Startup Disk may result in a “bless” error.


Hi There,

I have the same problem with a 80GB IDE HDD drive, which I want to clone onto a SSD (IDE to SSD (mSATA)) converter. The whole cloning process works well until the end of the clone process, when it states that the BCD cannot be copied to the windows partition. (see screenshot)

I have also tried this with an exact same IDE HDD drive of the same brand and size, but got the same message.

I have read a couple of treads regarding such issues, and even disabled the SIP via the csrutil disable command, but this also has no effect.

The windows version of the source disk is windows XP, and the file system is NTFS.

Can someone please help?



P.s. The make EFI bootable option does also not work.

Winclone doesn’t support XP any longer.


I had the same issue, managed to fix it and I just wanted to share what worked for me… Because let’s be honest, I’ll probably screw up my Windows Bootcamp drive upgrading to Mac OS XI “Atlantis” someday and I’ll need to re-google all this to re-find my own solution. :joy:

So, following what @tperfitt posted above showed promise but didn’t totally work. So in short, here is what I did to get mine to work :

  1. Use Winclone to set the Bootcamp drive to “Make EFI Bootable” (As shown here : https://support.twocanoes.com/hc/en-us/articles/115002318066-Switch-between-Legacy-and-EFI-Mode )

  2. (Optional if your drive won’t fully mount, and only mounts in read/write) Force-Mount the Bootcamp drive using NTFS for Mac ( https://www.paragon-software.com/us/home/ntfs-mac/ ) if need be. Mine was in “Hibernation” mode, and simply having it in read/write will not allow the change back to legacy boot mode - Winclone may do this as well somehow, I’m not sure. In my case I had to click on a NTFS for Mac Notification in the upper right when the drive mounts. This will open a separate menu with the option to force mount. I’m not sure how to get to this NTFS sub menu otherwise, sorry. I looked in the file menu options for NTFS for Mac but could not find the option to get to that menu, and I can’t recreate the steps and take screenshots because the drive now works properly. Figures, LOL. This is not the same as a typical read/write mount, this force-mounting warns you that you could lose data since the drive is in hibernation mode. I did it anyway and had no issue.

  3. Use Winclone to set the drive back to “Make Legacy Bootable”. - After the force mount you should be able to Boot back into windows without seeing that error.

My specs :

Mac Pro 2009 4,1 > 5,1
Mac OSX Mojave 10.14.6 booting from a Sonnet M.2 4x4 PCIE SSD
Booting to Windows 10 on a separate internal SSD drive
Radeon Vega VII - No EFI bootscreen, can’t use OPTION key at start to choose drive
Using Bootchamp to se startup volume to Windows BC

One more note… That sub menu shows up when you attempt to mount the Bootcamp drive in “NTFS for Mac” when you CLICK on one of the options on the NOTIFICATION similar to what you see here :

*The verbiage on the buttons may be different. For me, one of them opened a white sub menu with several options choosable by radial buttons. One of them (The second choice) was the force-mount option. Good luck. :+1:t2: