Creating new MacOS Boot Drive Breaks Legacy Boot Mode

#1

Where I started:

  1. I had two partitions on a 256 GB SSD:
    Mac OS - Mac OS Extended (Journaled)
    Windows 10 - NTFS - Created using BootCamp Assistant before Mac OS High Sierra and APFS
  2. Several upgrades until I got to Mac OS Mojave 10.14 - NOTE: For some reason at no point during the upgrades did the Mac OS Partition get converted to APFS
  3. I Bought a new 1 TB SSD
  4. I used Carbon Copy Cloner and Winclone to successfully migrate to the 1 TB SSD
  5. I recently realized that Apple will not allow me to upgrade beyond 10.14 because I do not have APFS
  6. I tried downloading 10.14.4 Combo Update and got the error message that APFS was required.
  7. I Resized my Mac OS Partition so that the layout is what is listed in the image:
    Old Mac OS - Mac OS Extended (Journaled) 10.14
    Mac OS - APFS - 10.14.4
    SSD Shared - exFAT
    Windows 10 - NTFS
  8. I used Carbon Copy Cloner to copy everything from Old Mac OS to Mac OS (APFS) Ran the 10.14.4 Combo Updater.
  9. I can successfully boot into and use Mac OS(APFS) with 10.14.4
  10. I used WinClone Tools -> Make Legacy Bootable…
  11. Reboot with Option Key Down and Only Mac OS Bootable Drives show up
  12. Boot in Mac OS Again and use the Startup Preferences to boot to Windows 10
  13. Reboot and Black screen and then a message that no Bootable Device found
  14. I used WinClone Tools -> Make EFI Bootable…
  15. Back into EFI crashing issues that can only be resolved by disabling several drivers including sound and legacy video
  16. So at this point I seem to be stuck with a crippled windows partition

12%20AM

Options I see:

  1. Use a method I have seen outlined where I clone the files on Mac OS to Old Mac OS and ensure I can boot up on the old Mac OS Journaled and then restore the partitions to the original state where legacy boot mode works

  2. Live without sound on Windows 10

  3. Wipe my whole system and start from scratch with a clean install of Mac OS Mojave and partition things the way I want and start over with boot camp and restore over the boot camp partition with Winclone and restore my Mac OS files with Carbon Copy Cloner

0 Likes

#2

What Mac hardware is it? Is it a 2012 MacBook Pro?

tim

0 Likes

#3
  • MacBook Pro (Mid 2012)
  • Processor: 2.6 Ghz Intel Core i7
  • Memory: 16gb 1600 MHz DDR3
  • Graphics:
    • Nvidia GeForce GT 650M 1024MB
    • Intel HD Graphics 4000 1536 MB
0 Likes

#4

I suspected it was a 2012 MacBook Pro. This is a known issue, though I am not sure why legacy is not working for you:

tim

0 Likes

#5

I believe legacy is not working for me because I now have too many partitions before the windows partition.
https://discussions.apple.com/thread/6465316

This article seems to suggest that MBR can’t understand more than 4 partitions.
With my current layout Windows is the 5 disk in order.
I am going to attempt to reduce the number of partitions and try the legacy boot again to see if it works.

Has Legacy boot mode been testing on a partition greater than 4?

0 Likes

#6

So I solved my own problem after some work and I still have my Mac OS drive as APFS so that I can get updates.

So I confirmed my suspicion was correct.
After getting back to where there Windows Partition was no more than the 4th partition, Legacy boot mode worked again.

Since Legacy Boot Mode = MBR or more accurately GPT/MBR Hybrid then you have to play be the old rules where MBR can’t handle more than 4 standard partitions.

It is important to note that this count includes all hidden partitions including the EFI and Recovery partitions that MacOS created by default. In my case I decided that the Recovery partition was not worth keeping around as anytime I have had a major issue the easier solution has been to boot off of the USB Installer I created that gives you all the same functionality.

So now I have the following Partitions:

  1. 200 MB Hidden EFI partition
  2. 600 GB Mac OS Mojave 10.14.4 (APFS)
  3. 300 GB Shared Data (exFAT)
  4. 100 GB Windows 10 Home (NTFS)

See this article to see all partitions in Disk Utility open a terminal window and type diskutil list and enter. This will list all the partitions. So for me it shows:
/dev/disk1 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk1
1: EFI EFI 209.7 MB disk1s1
2: Apple_APFS Container disk2 600.0 GB disk1s2
3: Microsoft Basic Data SharedSSD 299.9 GB disk1s3
4: Microsoft Basic Data Windows 10 100.0 GB disk1s4

I hope this helps someone else who is having the same issue with a MacBook Pro 2012.

0 Likes