Erase/Install Monterey M1 not completing

Hi Tim. We are using a workflow with Erase/Install Monterey. It is pretty basic (creates one user, one package, one script, one profile; set computer name, skip setup assist). This workflow has worked beautifully on our Intel Monterey, but we are getting stuck with M1’s. Upon erasing the drive group, it is not rebooting automatically (must manually reboot and reopen terminal). After the activation reboot, it comes up with an “OS needs to be reinstalled select startup disk”. Attached is a pic of the log. Any thoughts? I have cleared the MDS resource cache and rebuilt the disk image, still works on Intel, not on M1’s. Any help is appreciated.

was this resolved?


Hi Tim,
After using an OS DMG created by MDS (putting the installer in the “Applications” folder), we believe that solves it. I say believes b/c we were working on the machine that had tested incorrectly several times, but I got in 8x new M1Pro’s today so should be able to test tomorrow.
I really appreciate all your help and patience.

Today I wanted to set up an M1 MacBook Air, it went as follows:

  • Set up MDS to not install the OS. Greeted by error you can't save the file "items" because the volume is read only right after launching the workflow
  • Set up MDS to reinstall Big Sur. Greeted by error There are no users on this volume to recover right after launching the Big Sur installer through an MDS workflow. Unable to proceed.
  • Tried erasing the disk. Greeted by error No users available for authorization right after launching the Big Sur installer through an MDS workflow. After that, MDS complained that it didn’t find any Automaton, then killed every running process and unmounted the MDS stick automatically. Unable to proceed.

After that, every attempt through MDS failed in similar ways, and the MacBook was in bricked state. The only way I was able to get an OS reinstall going was by selecting “Install Big Sur” from recovery mode (i.e. the standard Apple way), which I guess downloads the installer from the Internet and installs the OS from scratch. Current time estimation until completion: 4,5 hours.

Update: After doing what described above (standard installation of Big Sur from recovery mode — not through MDS) it appears that the user accounts got created, packages got installed, and scripts got executed. So all the actions set up in MDS got triggered and executed, even if I didn’t launch the workflow from MDS. No idea what happened there…

I also have this problem

Can you help me to see what’s wrong