Error Copying Package to Volume in MDS

I’m just getting started with MDS, so maybe this is an easy one. I’m running MDS 1.3.1 on macOS 10.14.3 along with Winclone Pro 7.3.2.

I’m trying to create a workflow on an external hard drive that installs Windows from a Winclone package that creates a new partition that uses 90% of the destination drive and then installs Windows.

I’ve created and named the workflow and selected the folder that includes the Winclone package, but when I click “Save to Volume…” I get this error after a minute or two.

An error occurred embedding the package /var/folders/nc/8fd7l3w93h32nrvwcdw3zcgr0000gn/T/03262DBB-F5F7-4F2D-A0C9-2CC6C6F65975.pkg
Please check the package and free space and try again.

The drive I’m trying to install on is a 500 GB external SSD with nothing on it and is formatted as HFS+.

Hoping to verify that everything else seemed correct, I created a workflow to install a couple applications from their installer packages. This workflow was able to be sent to the drive correctly.

Any suggestions?

Update: I tried creating a new package that used an existing volume, but get the same error message.

it might be helpful to understand how MDS converts Winclone images for deployment and see if that helps figure out the issue you are having. MDS sees that the Winclone package is bundle type package and the macOS installer that MDS kicks off requires a flat package. To convert the Winclone package, the Winclone package is first copied from the source to a new folder on the source that has the package resources organized correctly. The package is then created. This package is then copied to the MDS Deploy workflow folder.

So it is possible that the source volume needs a lot of free space (up to 2X the size of the original package). Is it possible this is the issue?

We are looking at ways to optimize space usage in an upcoming update.


While the original Windows partition was 30 GB, the package from Winclone is less than 15. I’ve got 130 GB free on the computer I’m working on, so I don’t think that that is the issue.

Possibly related, I do get a Resource Needed message every time I change the package or its location. I also get the error unzipping message on the first attempt every time. A second try succeeds with no message.

OK, I did a bunch of work on figuring out this issue. It turns out it is due to a limitation on the size of a single file when creating new style macOS packages. If a single file is very large (like 10GB or larger), the pkgbuild will error out.

I think I have a solution, though, that should be much faster to prepare the Winclone package for installation. I am planning on adding an option to MDS to install the Winclone package from the recovery partition prior to install macOS. This means that the Winclone package doesn’t need to be converted and it means making the resources will be much faster. I will have the feature in a build of 1.5 in the next could of days on


Very nice. Thanks for your work, Tim! I’ll look forward to the build later this week.


The build is up here:

Make sure to mark the Winclone package as “before installing macOS”.


Hi there! Will these same modifications apply to other packages, not just WinClone? I’m looking to deploy quite large Adobe Creative Suite packages (9GB+) and am seeing this same error embedding the package with MDS 1.4 (10073).

I chalked it up to Adobe being super weird with how they package things (the .pkg doesn’t install any files in the standard sense, it just runs scripts that reference Adobe’s own per-app .zip files embedded in the pkg’s Resources folder) but haven’t given v 1.5 pre-betas a test to see what happens there.

Thanks for your hard work on this awesome tool!

Yes, it should work! Please report back and let me know what happens.



Added a 9.28GB Adobe package into an MDS volume via v1.5 (10864) and it appears to have worked great —no errors on the build at least!

I see it re-packaged the original .pkg to install to /private/tmp, then runs a postinstall script to install the original .pkg so all should be good :+1:

Great! Thanks for letting me know.


Thanks, Tim! My WinClone packages made it to my external properly now. If I run into more trouble, that seems like the sort of thing for a new thread.

1 Like

I’m running into this issue now but I don’t see that the Before OS is available in latest 1.8. Is it in the 1.9 preBeta or should I target a different one?


Are you selecting the option to install macOS? You will only see that option if you are installing macOS. If you are not, the option should be “when running workflow”:


I do have Install MacOS but the only options I have for packages are when running workflow or after MacOS installation. I’m currently trying on MDS 1.9(19065)

Select “when running workflow” for the winclone package and then it will be installed prior to rebooting and installing macOS.


I still get this error, doesn’t seem to matter the version I try or choosing. I am installing Mojave in the workflow but only options for packages are When Running or After MacOS and both generate the same error. Currently trying with the latest MDS Version 1.8