Error - os image was not created

I’m running MDS Version 3.0 (30108) on MacOS 10.15.5 on a MacBook Air (Retina, 13-inch, 2018) . When trying to download any version of MacOS within MDS to a folder on the desktop I get the following error.

The OS Image was not created successfully. Please grant /Library/PrivilegedHelperTools/com.twocanoes.mdshelpertool Full Disk access in System Preferences->Privacy->Full Disk Access and reboot. This is required so MDS can access removable volumes.

I’ve followed the instructions and also added MDS to full disk access but it still only download .sparseimages of the os with a content folder containing several GB in there downloads folder.

We are tracking this issue. In the meantime, please download to a folder in /Users/Shared. It isn’t protected by TCC and you won’t have that error.


Download the MDS app to the /Users/Shared folder?

I am trying to save a disk image of a workflow and I do not have permissions to write to my local drive. I think this is related because I cannot select the PrivilegedHelper Tool in the Privacy Full Disk Access control panel to add it.

When it prompts you to save, select a folder in /Users/Shared.


I still receive this error when downloading a macOS Installer to a folder in shared


Any update on this? I’m experiencing the same issue and unfortunately am pressed for time. Any help would be greatly appreciated.

After 3 attempts I got it to work by saving to the shared folder as stated.

Great software!!!

1 Like

Still getting the same error when downloading 11.4 (20F71) or any other Big Sur version ‘The OS Image was not created successfully. Please verify you have enough free space and try again’.
There is plenty of free disk space of course (250Gb).
Downloading to /User/Shared/macOS/ does not work unfortunately and still gives the same error.
Tried on version 4 as well as 3.6
Interestingly 10.15.7 (19H15) does download to the same location.

Press command-L to show the log and it should say why it is is failing.