External TB3 Bootcamp on 2020 iMac

Hi All –

Wanted to share my experience of trying to get bootcamp to work on an external TB3 drive with my 2020 T2 iMac. It seems like this is an active topic, so I’m sharing in hope this might help.

I have successfully installed Windows 10 via bootcamp on my internal drive; however, I can’t get it boot externally and have tried the following:

  1. Vanilla Winclone 8.2 image to external drive
  1. Vanilla Winclone Beta 9 (48137) image to external drive
  • Reset PRAM
  • Manually inject Bootcamp drivers using new Windows Support inject feature

Unfortunately, I haven’t been able to get any of the above permutations to work. All end up on BSOD INACCESSIBLE_BOOT_DRIVE after selecting the boot drive upon startup.

The behavior is consistent across all cases - select the windows drive up startup, Windows logo pops up, and then my TB3 drive flashes (like during a restart). After the flash, Windows eventually goes to BSOD above.

Also interesting to note, I get this exact same behavior when trying to accomplish this via a VirtualBox VM installation. It appears my iMac can no longer reach my TB3 drive after the Windows logo pops up and TB3 drive “restart flashes”.

Hope this helps!

Forgot one thing – also attempted this RegEdit fix on my Winclone 8.2 images / transfers with no luck.

You need to do two registry edits using RegEdit, before you clone (or via Parallels if you have the external drive)


1. Under HardwareConfig Click on entry with a bunch of numbers (Its a UUID) and change BootDriverFlags to 14 in hexadecimal.
2. Under MountedDevices delete all entries, then delete MountedDevices complete.

Quick update. I used the latest Winclone Beta update v9.0 48143 to attempt the above external TB3 bootcamp install.

Unfortunately, I’m getting the same error after using this latest beta. I recreated a winclone image using 48143 and get the INACCESSIBLE_BOOT_DEVICE error both with and without installing the bootcamp drivers. (My bootcamp partition boots up just fine)

Thanks for the follow up, Tim.

I’m using an external OWC Thunderbay 4 (TB3 version) for this and it turns out they offer no additional Windows drivers. Unfortunately, it seems like I’m out of luck. Appreciate the support. .Will reply separately for a refund.