Failed Win10 image restore for Macbook Pro 2020 (Intel)

Hi there,

I am currently using a 13" Macbook Pro 2020 (the last generation using the Intel CPU). After a botched Windows 10 update that led to a blue screen that I cannot fix no matter what, I turned to a Winclone restore.

While the restore was successful, when trying to boot up, I received an error saying “A required device isn’t connected or can’t be accessed” (see screenshot attached)

I honestly don’t recall seeing such an error in my years of using Winclone. However, I do note that somehow with this laptop, I could no longer install Windows 10 directly without using Bootcamp. Somehow, the installation would just hang due to missing drivers. Appreciate your support as I need my Windows partition up ASAP.

For reference, I am currently using Winclone 8, and my Windows 10 version is 20H2.



This does seem like it can’t find the mass storage device. Do you have any other drives connected? If so, try removing them when booting up. Also, try booting into safe mode and see if that gets you further.


Nope, I don’t have any other drives connected when booting up. In fact, I recalled that Windows 10 couldn’t detect my SSD when I tried to install it without Bootcamp. Pretty sure it is a missing driver issue.

How do I boot into safe mode in Win 10? Hold down the shift key after selecting the Windows partition?


Also, just for context, I have a Macbook with a touchbar, so I won’t be able to access function keys when I am in the boot manager or any system screen mode.

Appreciate any suggested solutions as I have been going without my Windows partition for more than a week now.

The easiest way to get around the touchbar / fn keys issue is to plug in an external USB keyboard.


Hi Tim, noted on this. I am able to get the external keyboard to work. However, I am unable to get into Safe Mode. Also, I am still not hearing how do I solve the bigger issue on how to troubleshoot the error or understand what was it about the image restore that caused this problem.

Appreciate if we could go into some details. Thanks.

I just purchased winclone for a 2015 macbook pro that I had to have repaired, when I tried to restore got the same error & cannot fix

The error is probably due to a driver not found issue. If you just got back the same unit from repair, it shouldn’t require any different drivers. Was the hardware the same when you were restoring the image?


There was totally no change in hardware. As mentioned right on the first post, this whole thing happened because of a botched Win10 update, which I rolled back to. I made sure I have everything else disconnected except for the charger when I tried to boot up.