Formatting SSD to achieve matching block size?

Hi,

I just picked up a Samsung 2TB T7 SSD. I want to partition it with 2 partitions, 1 for CCC backup and 1 to use as an external Bootcamp partition.

My host is a 2020 iMac running Catalina 10.15.7.

I attempted to partition the SSD identically to my internal drive:
GUID Partition Map
Partition 1: APFS Container
Partition 2: exFat (reformatted to NTFS by Winclone when restoring)

The exFat partition on the internal drive returns 4096 Bytes for the Device Block Size
The exFat partition on the SSD returns 512 Bytes for the Device Block Size and 4096 Bytes for the Allocation Block Size.

Winclone will not allow Block-based operations with this reported mismatch in Device Block Size. WIM is much slower and without block-based operations, volume-to-volume actions are not allowed.

I’ve tried a number of things and done a fair bit of Google searching to see if there’s an obvious way to format the bootcamp partition on the SSD so that it returns 4096 Bytes for the device block size. I’ve had no success.

I’ve tried using newfs_exFat in the terminal, but I’ve not been able to get the desired result
I’ve tried using a Windows machine to format the partition directly as NTFS, but I can’t get the Device Block Size set at 4096 Bytes.

I’ve looked for 3rd party partitioning tools for the Mac, but most don’t seem to handle APFS.

I’m hoping that others have had success here or have some suggestions on other things to try.

You can change the filesystem block size, but the physical block size (which is what is causing the issue) cannot be changed. The only current option for Winclone is to create a WIM-based image and then restore it to the different block-sized drive.

tim

Thanks for the update Tim.

I was concerned that it might be a fixed value by the hardware/firmware/manufacturer. There’s a fair bit of misleading info out there.

I did attempt what you suggest and was not successful:

  • Created a Winclone image of my working Bootcamp partition on the internal drive using WIM mode
  • Restored the WIM created image to the Bootcamp partition on the Samsung T7 external SSD
  • attempt to boot from Bootcamp on the external SSD
  • Windows 10 boot image appears
  • Waiting circle animation active
  • Screen blinks
  • More waiting circle animation then…
  • Reboots into macOS

I’m not sure why this would fail. It’s a direct copy of a working bootcamp partition on the same machine. Drivers should be good. It appears to be booting from the correct (external) partition. SIP is off, external device booting is allowed.

Any ideas?

Hi Tim,

Hoping you might take a look at my reply (above) and have a solution for me.
WIM based cloning didn’t work.

Thanks,

Steve

Try booting into safe mode and see if it is at least able to boot up. I have heard of reports of pending Windows updates that can cause this behavior and safe boot gets around that to cancel the update.

tim

Steve —

I feel your pain. After many TS attempts and posts on this forum (with exactly the same results you are apparently experiencing) I have simply given up on trying to get this product to do what it claims to be able to do — create a bootable Windows partition on an external SSD.

While Tim did at one point offer me a refund (not really a solution, is it?) I look forward to a workable and reliable fix and will continue to monitor this board in hopes that a real solution will one day be a reality.

In Sympathy,

Bruce

Hi Tim,

No luck so far.
I haven’t found a reliable way to get into safe mode when booting from the external SSD. I eventually got there by simply rebooting 4 (or more) times in a row (I didn’t count). But choosing safemode gave me an error dialog: sihost.exe - System Warning, Unknown-Hard Error with an OK button. Clicking OK gave me a black screen with a mouse pointer and a flashing wait circle. I waited 10+ minute then rebooted.

To recap:

  • New iMac running Catalina 10.15.7
  • Bootcamp installed successfully on internal Bootcamp partition
  • I used WIM mode to create an image of the working Bootcamp partition
  • I restored the image to a Samsung T7 SSD, freshly formatted as GUID, 1 partition, exFat
  • Restoration completed successfully
  • SIP is off and external boot devices are allowed
  • When I boot from the Samsung T7, it shows the 4 pane “window” with a wait circle, then reboots to macOS after a bit.
  • Booting into Safe Mode gave me the sihost.exe error.

Any ideas?

Is there a secret to getting into safe mode while booting? I tried F8 and F5 without success.
Also, is there a way to choose an external boot device as the default startup device in macOS? I am not presented with the external drive from the startup disk panel in system preferences, despite the drive being attached, mounted and visible in Finder.

Bruce,

Thanks for your comments. Sorry we’re in this together! Frustrating for sure.
I’ve been on both sides of the fence as a developer myself. I’m hoping Tim and team have success overcoming the changes being thrown at them by Apple and Microsoft. Challenging stuff.

Winclone has served me well in the past. The current issues are a bummer.

I may have to punt and wait until TwoCanoes pulls a rabbit out of the hat.

Best,

Steve

Thx, Steve. A challenging situation, for sure. I’m a long-time WinCloner (backups) and have my fingers crossed.

If anyone can solve it I’m sure Tim will be the one — hours in a day, I guess. Perhaps you’ll hit the jackpot?
Cheers,
Bruce

Hi Tim,

I’m sure you have your hand full. Hoping you might carve out a moment to answer the various questions above. I’m trying to make a decision about how to proceed and whether I should return the T7.
If there’s a better/faster way to connect, let me know.

Thanks,

Steve