How do I resize bootcamp part on SSD APFS?

Mac OS Mojave
Late 2013 MB Pro with 500GB Drive - APFS
Backed up existing 100GB bootcamp using winclone7 to external usb 3 drive
Then did a filesystem based backup of bootcamp win10 machine
Then deleted the bootcamp partition using disk utility
Tried to use bootcamp assistant to create a boot camp partition - error saying I didn’t have enough space on startup disk - 40MB required.

Here are the details of SSD:
MIKEs-MBP:~ mikeross$ diskutil apfs resizecontainer disk0s2 limits
Resize limits for APFS Physical Store partition disk0s2:
Current Physical Store partition size on map: 398.1 GB (398068789248 Bytes)
Minimum (constrained by file/snapshot usage): 398.1 GB (398068789248 Bytes)
Recommended minimum (if used with macOS): 398.1 GB (398068789248 Bytes)
Maximum (constrained by partition map space): 398.1 GB (398068789248 Bytes)

APFS Containers (2 found)
±- Container disk1 FF254318-391B-4542-83BB-FC871C59D969
| ====================================================
| APFS Container Reference: disk1
| Size (Capacity Ceiling): 398068789248 B (398.1 GB)
| Capacity In Use By Volumes: 269165527040 B (269.2 GB) (67.6% used)
| Capacity Not Allocated: 128903262208 B (128.9 GB) (32.4% free)
| |
| ±< Physical Store disk0s2 32967C19-1B9A-408B-A479-038F90AC7CB7
| | -----------------------------------------------------------
| | APFS Physical Store Disk: disk0s2
| | Size: 398068789248 B (398.1 GB)
| |
| ±> Volume disk1s1 2AD91444-1BFF-3369-A925-D5202560ABB2
| | ---------------------------------------------------
| | APFS Volume Disk (Role): disk1s1 (No specific role)
| | Name: Macintosh HD (Case-insensitive)
| | Mount Point: /
| | Capacity Consumed: 265234546688 B (265.2 GB)
| | FileVault: No
| |
| ±> Volume disk1s2 BA2724AF-390A-4D06-AB50-F23DF4E0C279
| | ---------------------------------------------------
| | APFS Volume Disk (Role): disk1s2 (Preboot)
| | Name: Preboot (Case-insensitive)
| | Mount Point: Not Mounted
| | Capacity Consumed: 45264896 B (45.3 MB)
| | FileVault: No
| |
| ±> Volume disk1s3 4AE68998-03E3-4D69-857A-7BED4FDD3566
| | ---------------------------------------------------
| | APFS Volume Disk (Role): disk1s3 (Recovery)
| | Name: Recovery (Case-insensitive)
| | Mount Point: Not Mounted
| | Capacity Consumed: 512389120 B (512.4 MB)
| | FileVault: No
| |

±> Volume disk1s4 0B384704-21E0-4F63-AAF3-C31F86B26E79
APFS Volume Disk (Role): disk1s4 (VM)
Name: VM (Case-insensitive)
Mount Point: /private/var/vm
Capacity Consumed: 3221278720 B (3.2 GB)
FileVault: No

±- Container disk3 DC200CA0-E2B4-42AC-9204-0ECDE0C5C93B
APFS Container Reference: disk3
Size (Capacity Ceiling): 101999247360 B (102.0 GB)
Capacity In Use By Volumes: 123994112 B (124.0 MB) (0.1% used)
Capacity Not Allocated: 101875253248 B (101.9 GB) (99.9% free)
±< Physical Store disk0s3 3AD6B07A-A574-4420-8318-6B946DC2C798
| -----------------------------------------------------------
| APFS Physical Store Disk: disk0s3
| Size: 101999247360 B (102.0 GB)
±> No Volumes
MIKEs-MBP:~ mikeross$

Have you tried creating the partition in Disk Utility? Create a exFAT partition and it will shrink APFS and make a separate exFAT partition.

Also, I didn’t know about the “limits” option. Thanks for that.

Thanks for the reply.
Long story short - I was finally able to create a resized exFat partition and did a Winclone restore that went cleanly. I could not boot into windows. Received error that stated “
windows failed to start a recent hardware change might be the cause”. I was able to use disk partition and reformat to ExtFat and do a clean install of windows and was able to boot into it no problem. When I then reformatted again and do a iWinclone restore, I get the windows failed to start error again. I found these instructions on repairing the MBR.

When I issue the command bcedit /export c:\bcdbackup I receive an error stating "the requested system device cannot be identified due to multiple possible occurrences”

Any ideas?


Mike Ross

Was this all on the external drive?

Internal SSD formatted APFS. Winclone backup is on an external USB drive

Thanks. Is this Windows 7 or Windows 10? We do extensive testing on exactly what you are doing, so it definitely does work and should not require modifications to the MBR or BCD.


Win10. What is interesting is if I create the partition then do a clean install of win10. I can boot into it no problem. If I create the part then restore from winclone backup I get the boot error l. Makes me think there’s an issue with with the backup or restore

Finally got the restore to boot. Had to turn off System Integrity Protection (SIP) on the MBP. Then from the tools menu in Winclone, select make EFI bootable. You can close the case.
Mike Ross

1 Like