.htacces in MDS webservice

Hello there,
I’m trying to install .htaccess for the munkiwebsite.
I’ve of course put a .htaccess file in the munkirepo directory but no go.

Turns out I have to add the htaccess part in the com.twocanoes.mds.http.conf
located here: /private/etc/apache2/other/com.twocanoes.mds.http.conf

AuthType Basic
AuthName "Munki Repository"
AuthUserFile /Volumes/some/path/to/munki_repo_htaccess/.htpasswd
Require valid-user
#Require all granted

Works as expected BUT

As soon as I restart the webservice From within MDS button, htacces settings ARE wiped out.

I can bypass by using the macOs builtin function:

/usr/sbin/apachectl stop
/usr/sbin/apachectl start
/usr/sbin/apachectl restart

Would be wonderfull to be able to include an option for a .htaccess in MDS.
at least for the munki repo and eventually for any website.

Many thanks and very great Tool :wink:

Please submit a feature request here:



Many Thanks. it is done.