I'm having trouble making Legacy bootable.

I have a macbook pro 2012 running High Sierra and my drive is formatted with guid partition map. Whenever I try to boot into Windows, I get an error that says “No bootable device – Insert boot disk and press any key”. I used Winclone 6 to change the boot option to efi and it beared the same results only with the icon showing in boot options. I tried to change the boot mode to legacy mode and got an error that says “Could not mount /dev/disk0s3 Read/Write”. I have a picture below. What should I do? Thanks in advance!

was the image create as a WIM (file-based) or block-based image? It might help to create a WIM-based image and try restoring that.

tim

I am not sure what you mean by WIM (file-based) or block-based image but this copy of windows came from my old internal hard drive. I upgraded to an ssd and my old internal hard drive got unintentionally formatted. Using another windows computer, I ran a data recovery software and it recovered my partition. I then manually copied those files to my internal ssd. To make sure I wasn’t missing any files I copied all of the recovered folders. I know it is an odd situation but I hope you can help me. Thanks in advance!

Due to permissions, it would probably make more sense to install Windows then migration the data manually.

tim

Oh, ok then. I’ll try that! But before I do, I want to understand what is going on. What could be the problem (if it’s not to much to ask for)? Would changing the the format from guid partition map to master boot record enable windows to be bootable? I thought this had something to do with it because when when I first tried to make legacy bootable, I was met with this notification popup reading “Are you sure you make Windows to be MBR Bootable?” There seems to be a connection with legacy boot and MBR and maybe changing the format would allow this? I got this laptop in 2012 when it came out with macOS Mavericks and with the original hard drive but I don’t remember what the scheme (guid or mbr) it had. What do you think about all this? I don’t have much on my laptop so wiping the drive and reinstalling everything isn’t a problem for me. I have a picture below. Again, thanks in advance!