Incremental Backup Error: Cannot update image with Volume ID

Hi,

I’m trying to set up Incremental Cloning for the first time. I have successfully created the image - which is one an external SSD.

My Bootcamp partition is on the internal Macintosh HD - created using Bootcamp Assistant in the normal way. When I try to select the partition in the Incremental Cloning Config, I get the following error:

"Cannot update image with Volume ID
The associated Windows volume ID could not be updated in the image at /Volumes/Bootcamp BU/Bootcamp.winclone. Please check permissions and try again
"

What does this mean - and how should I go about fixing it?

The only thing I can think of which is non-standard is that for convenience, I’m using a Parallels VM to use the Bootcamp partition from within MacOS. But I can still boot to the Bootcamp partition directly, if I want to.

The volume ID is saved to the Winclone image itself (which is a “bundle” type package) and this error means it can write inside that “bundle” (which is actually a folder). Try control clicking on the image, select Show Package Contents and a folder will open up. Try creating a new folder in that folder and see if you get a permissions error. If you do, that is why Winclone is failing. it can write to inside the image.

tim

Thanks Tim.

I’ve shown package contents of the winclone image. And I’ve created a new folder inside the package - without any permissions error.

What should my next step be, please?

Ben

The other piece of information that is required is the partition ID, which on a GPT disk is called a “mediaUUID”. If you do a "diskutil info " in terminal, it will show the mediaUUID (under Disk/Partition UUID):

It is possible that the disk is formatted as a non-GPT disk and doesn’t have a media UUID.

tim

OK, thanks - this is what I have:

Device Identifier:         disk0s3
Device Node:               /dev/disk0s3
Whole:                     No
Part of Whole:             disk0

Volume Name:               BOOTCAMP
Mounted:                   Yes
Mount Point:               /Volumes/BOOTCAMP

Partition Type:            Microsoft Basic Data
File System Personality:   NTFS
Type (Bundle):             ntfs
Name (User Visible):       Windows NT File System (NTFS)

OS Can Be Installed:       No
Media Type:                Generic
Protocol:                  PCI-Express
SMART Status:              Verified
Volume UUID:               3962CF26-C68B-4778-ADF1-E575CC660993
Disk / Partition UUID:     DD0BBADF-4F05-4407-AF6A-E1A1EA241C97
Partition Offset:          952314626048 Bytes (232498688 4096-Byte-Device-Blocks)

Disk Size:                 48.2 GB (48240787456 Bytes) (exactly 94220288 512-Byte-Units)
Device Block Size:         4096 Bytes

Volume Total Space:        48.2 GB (48240783360 Bytes) (exactly 94220280 512-Byte-Units)
Volume Used Space:         36.5 GB (36463960064 Bytes) (exactly 71218672 512-Byte-Units) (75.6%)
Volume Free Space:         11.8 GB (11776823296 Bytes) (exactly 23001608 512-Byte-Units) (24.4%)
Allocation Block Size:     4096 Bytes

Read-Only Media:           No
Read-Only Volume:          Yes

Device Location:           Internal
Removable Media:           Fixed

Solid State:               Yes
Hardware AES Support:      Yes

I’m looking at the code right now, and the ways it can fail:

  1. No UUID on disk. You verified that isn’t true.
  2. It can read or write to the productInfo.plist in the image. Do you see a file named productInfo.plist in the image?

tim

Yes productinfo.plist is in the image. Here are the contents:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <dict>
    <key>bootenv</key>
    <string>EFI</string>
    <key>buildLabEx</key>
    <string>18362.1.amd64fre.19h1_release.190318-1202</string>
    <key>currentBuildNumber</key>
    <string>18363</string>
    <key>deviceNode</key>
    <string>/dev/disk0s3</string>
    <key>edition</key>
    <string>Professional</string>
    <key>mediaUUID</key>
    <string>EE400663-9BC6-4697-B03B-F6177E2D619A</string>
    <key>product</key>
    <string>Windows 10</string>
    <key>winPEBootable</key>
    <false/>
    </dict>
</plist>

And I’m able to edit and save changes to the above productinfo.plist (don’t worry I’ve changed it back!)

Any further suggestions, possibilities gratefully received… :slight_smile:

I had a thought. Perhaps it is TCC that is blocking it (the new privacy controls). Try moving the image the root of your home folder (or to /Users/Shared) and see if it works.

tim

That was a good thought, Tim! It worked!

So what should I change to allow it to use my external SSD?

Many thanks for your help.

Ben

OK, Progress. Having done the above, if I now change the destination back to the original image on my SSD - with the source partition already set and accepted - I can now run the incremental backup.

However - it runs for several minutes and I then get the following error:

**There was an error updating the image. Verify Windows was shut down cleanly, run CHKDSK and try again.**

I’ve run CHKDSK and made sure that Windows was shut down properly, but I still get the above error.

If you look in the log, does it show any file related errors? You can open the log right in Winclone.

tim

I also use Parallels by getting it to run the version of Windows on Bootcamp. After an initial first image and 3 successful incremental back ups, I’ve also hit a snag with the same error message “There was an error updating the image. Verify Windows was shut down cleanly, run CHKDSK and try again.” I’ve shut down Windows via bootcamp as well as in Parallels. For me, in the log, two error codes come up. The first is “ERROR: Exiting with error code 47” and the second is [ERROR] Can’t open “/Volumes/Backup Plus/filename.winclone/Windows.wim” read-only: No such file or directory”

The issue is that Winclone cannot write to the WIM file on the external drive. Check permissions and try again.

tim