Hi. I’ve got a MacBook Pro 2019 2x Thunderbolt 3 and I’ve got a bit of a problem.

My internal SSD is 120GB which is way too small for 2 OSs.
So I installed Windows and then used Winclone to move it to an external SSD.

The Block Size of my internal SSD is 4096 and the external one is 512. IDK if this makes a difference but I’m stating it anyway.

Prior to making the Winclone backup, I did run CHKDSK to make sure there were no errors and there weren’t any.

I followed this support page “Resolving INACCESSIBLE_BOOT_DEVICE Error after restoring Winclone image” and this one “Create a Windows 10 Bootable USB Flash Drive on a Mac” to make the USB and everything worked fine. it found the drivers and copied them to the external SSD but when I reboot, I got the “0xc0000001” Error.

I’ve heard that accessing the “Repair your computer” might be able to fix this error but for some reason, I’ve only ever seen it appear after the language selection screen on Macs before 2014 and on Windows PCs.

So yeah, does anyone have any idea why this isn’t working?

Thank you!!

I was experiencing a similar issue.

First, I created an image from Bootcamp which is a fresh Windows installation 1903 18362.30.
Then I restored the image to my external SSD device.
When booting Windows, it shows the same error 00000001. sihost.exe unknown hard error.

I solved the error by doing sysprep from the original Bootcamp in the internal SSD.
Then created and restored the image to the external one. Error is gone eventually and I can now boot from my external SSD

I am using Macbook 2018 15inch with Catalina 10.15.1

Hope it helps.

1 Like