Installation Windows 10 on an external SSD (USB3.0)

Hi all,

I have been using Winclone for longer time now. As I wanted to use it to install another Windows on my other Mac (using an external SSD again), I ran into issues and cannot figure out where the problem is.

I am using:

  • Winclone 7
  • Macbook Pro Retina Early 13 with Public Beta of Mojave
  • External SSD (SSD of make “Crucial” mounted into an external drive which I use also on my other Mac, working well)

What I tried:

  1. Installing Windows via BOOTCAMP assistant
  2. Installting BOOTCAMP windows Support software (all drivers etc)
  3. Set BootDriverFlag to 14(hex)
  4. Run Sysprep and shutdown
  5. Boot into Mac and run Winclone -> Saving image on my NAS
  6. Tried both ways (end in same result): Restoring the image via image->drive function and also drive->drive cloning (destination drive formatted GUID Partition Table / FAT system)
  7. Direct booting results in "Error loading operating system“
  8. After booting to macOS again and making the device “EFI bootable” via Winclone, I can manage to boot windows and the Windows setup starts (usual process after “sysprep”)
  9. But it gets stuck, restarts and shows up Windows is not working properly and has to be repaired, using external Repair tools

I am stuck and this point. Any ideas?

Thank you so much for your support.



I now tested further, once with sysprep and BootDriverFlag 14 and once without…
With BootDriverFlag 14 and sysprep:

  • Error “Error loading operating system”
  • After making the drive “EFI Bootable” via Winclone: Issue as described in my initial post above (PC crashing @ about 37% of Windows Prepartation and then error message “PC has to be repaired”. After retry, PC only crashing…

Without BootDriverFlag 14 and without sysprep:

  • So I tried that one: Link
  • Result: Computer starts to behave again like described above -> Windows tries to startup but crashes only…

Further note: The installation itself somehow seems operable since I am able to use Parallels Desktop to open the BOOTCAMP partition as virtual machine, directly from the external SSD… Only boot directly into it does not work.

What else could I try… :frowning: Thanks for your support guys.

Have you ever gotten this hardware and drive combination to boot Windows externally?


Yes, i did, though in a more complicated way, using a virtual machine (use the external drive for windows installation in the virtual machine and booting from it directly, right after the first restart is asked for by windows installation).
So in principle, the hardware seems to allow it. Just did not manage to do it with Winclone which would have been much easier :-/

I am not sure whether it is allowed to post the link to an external site here. But if yes, I could post it just in case anybody else has a similar problem (or for your review of the virtual machine solution).

I would be very happy though if my beloved Winclone would be able to do the job as well :slight_smile:

// edit: In addition, I would like to mention that it was possible to boot from a winclone-restored external windows using Parallels Desktop. It immediately recognized it as a BOOTCAMP and allowed to boot from it. So in principle, Winclone restored well, but only lacks making it bootable directly (not using any virtual machine software). Neither making it „legacy“ nor „EFI“ bootable repaired the situation (as stated in my first post).
Once more many thanks for support.

Yes, external booting can be tricky. Did you try external booting with the same drive on the other Mac? I am trying to see if the firmware on the 2013 and the external drive combination is the issue, or if it is the windows install.