Internal HD not visible in Windows after cloning to external SSD

Hello all,

I was just wondering if anyone else has experienced this. I like many originally had my bootcamp and OS X running from the internal HD on this iMac, however I recently with the help of Winclone managed to clone the bootcamp partition to a USB SSD and that is running fine except for one problem.

I am not sure this is related to the clone process but Windows is now unable to see my internal SATA HD, which seems to be because the SATA controller won’t load/start due to an IO Adapter Hardware Error (10).
However, if I boot into Windows Setup it is able to detect the HD and it’s partitions and if I format the FAT32 partition I created in OS X and boot into Windows on the SSD it then works. That is unless I boot back into OS X and then the error reoccurs on the next boot into Windows.

I can’t tell if this is due to the cloning process with the registry or driver setting being confused, but I am at a loss as to how to get it work reliably.

Any help or advice is appreciated,

It definitely seems driver related. I would start with downloading the most current Boot Camp drivers from the Action menu in Boot Camp Assistant, and then reinstalling in Windows.


I agree, but I haven’t been able to figure out the cause yet :confused: I have tried reinstalling the BC drivers too, which unfortunately doesn’t help.

The only way I have found for it to work so far is to install a clean copy of Windows on to the internal HD and then for some reason it doesn’t have a problem with it. However this seems to confuse Startup Disk in OS X as it then only shows the internal BC as an option unless I unmount the volume with Windows on it.

The only thing I haven’t tried so far is cloning or installing a fresh copy of Windows on to the external drive and see if the same issue occurs.