Issue migrating internal Windows partition to external SSD

Hello all,

I’m at my wits end with this. I have a fully-functioning Windows 10 Bootcamp partition on my internal SSD on a 2017 Macbook Pro running MacOS 11.6. I’m trying to migrate to a SanDisk portable SSD. I was able to successfully create an image of my Windows Bootcamp partition w/o any issues. (The volume-to-volume transfer failed due to a block mismatch error, but that seems common.) The first few tries, Winclone failed to create the EFI files to make it bootable (read-only errors) when cloning to the SSD. After troubleshooting, I figured out that the EFI partition was non-existent on the SSD and Winclone was trying to modify the main partition that it just created, which it of course could not do since it was NTFS (NTFS being generally unreadable by MacOS). To fix that, I reformatted the SSD to ExFAT, went to a Win10 computer, and used ‘diskpart’ to manually create the partitions. After switching to the SSD partition, the specific commands I used in diskpart were:

shrink desired=500 '(freed up 500 MB)
create partition EFI size=200 '(created an EFI partition of 200 MB)
format quick fs=fat32 label='System'
create partition msr size=128 (not sure if this was needed)
bcdboot c:\windows /s e: /f all ('e:' being the SSD drive letter)

I then went and restored the image in Winclone to the SSD. This time the operation completed successfully and Winclone was able to modify the EFI partition.

With that issue fixed, I selected the SSD in the MacOS bootup menu, but now I’m getting the dreaded bootup BSOD 0xc0000001.

I’ve tried using a recovery USB, booting up into WinRE, then using the command line to perform

bootrec /rebuildbcd

That identifies the correct windows installation, and performs the operation successfully, but upon rebooting an ‘automatic repair’ is attempted that fails and brings me to another WinRE (not sure if it’s being ran off of the internal or external SSD, but my USB WinRE is removed at this point). I’ve tried to mount the EFI partition on the external SSD and perform the bcdboot command above on it directly, but it then loops me back to the BSOD error with the option to enter the recovery console.

(One note - I’ve read in other posts that some have had success using ‘sysprep’ before performing the image, but I’d strongly prefer not to do that as the partition is perfectly configured with all drivers operational. It took me a while to get to that state, so I’d rather not have to reinvent the wheel. I also don’t understand why performing sysprep would effect the EFI boot partition.)

Edit: Using Rufus in Windows, I was able to create a bootable ‘Windows To Go’ from a fresh Win10 iso file on my external SSD without any Bootcamp drivers. This install was able to be booted to without issue. That tells me that it’s not a lack of Mac OS SSD drivers that’s giving me issues, but something else that I can’t figure out. It could always just create a new install and go from there, but that would be a monumental hassle for me, and would negate why I purchased Winclone in the first place.

Any ideas?

You can get a refund here:


Thank you for the reply.

Don’t misunderstand, I wasn’t looking for a refund, but a solution. I have a feeling that it has to do with a misconfiguration of the BCD, but I’m not (yet) smart enough to troubleshoot it.

And I do appreciate the offer of a refund, but it wouldn’t be fair. I’ve already used Winclone without an issue on another MacBook and it performed perfectly (I’m using the included second license). I feel I already got my monies’ worth from my first use, even if it doesn’t work out on this occasion.