Mac Pro ,1 and Bootcamp on NVME (via PCIE)

Hi,
I’ve tried to clone my Bootcamp partition (Windows 10) that’s currently running on an internal SSD of my Mac Pro 5,1 (Mac OS Mojave) to a new NVME drive that I installed via a PCIE adapter.
Drive is showing, everything works fine and completes without errors but when I try to boot from it, I’m getting a “No bootable device” error.
What I tried:
Convert to EFI Boot (successful)
Convert to Legacy Boot (successful)
Taking out the internal Bootcamp drive of course…

I can select the drive in the startup settings in Mac OS (I don’t have a bootscreen unfortunately as I have a non Mac GPU) and it shows as a normal external drive in Finder.

What am I doing wrong?

One more thing: I‘ve checked the SSD that I‘m trying to clone and it runs windows 10 with only MBR. Diskpart shows no GUID present on the drive… Strange. I guess this is due to having windows 7 installed initially and upgrading to Windows 10 a few years ago.

I found an issue with “Make EFI bootable” that is resolved in build 46128. See if that resolves your issue. You can download it here:

https://bitbucket.org/twocanoes/winclone-beta/downloads/

Hi. Thank you but unfortunately no, still same issue. Make EFI bootable completes successfully, I‘m selecting the drive to reboot in system prefs and on startup I‘m getting „no bootable device“.

have you tried installing Windows directly on that drive and that interface, and does it work? that would be an interesting datapoint.

tim

Yes I did, actually. Windows 8 though, since the latest image of windows 10 was too big to burn on a „regular“ DVD… was able to install windows 8.1. from DVD and was able to boot from it afterwards.