MacOS could not be installed on your computer

Hello, I am trying to do a proof of concept for this software.

Successfully made a .dmg from MDS. OS is High sierra, which I verified it was pointing to a copy of that OS.

I start the process, with the /…/…/ run command in terminal from recovery mode.

It starts to run, then a screen pops up that says…
MacOS could not be insgalled on your computer.
The path /system/installation/packages/OSinstall.mpkg appears to be missing or damages.
Quite the installer to restart your computer and try again.

This is not the path to get to the OS selected in the MDS creator.

What am I missing?

This video walks you through step by step :

Nice video, but it is not helpful. I have watched all the videos I can find. I have tried these two steps…

"If you are saving an MDS workflow to a bootable external volume, be aware that the macOS installer presents the volume name as “/Volumes/Image Volume” rather than /Volumes/. This can cause issues with the workflows since the resources are accessed by the volume name. To resolve this, you can do one of two solutions:

  1. Create two HFS+ partitions on the external drive. Install the bootable macOS on one partition, and save the MDS resources to the other partition. You can then run the command using /Volume//run/
  2. After installing macOS to the external volume, rename it to “Image Volume” then save the resources from MDS to the Image Installer volume. The workflow resources will then be referenced by the correct name and you can run the workflow by running /Volumes/”Image Volume”/run"

I have removed all other tasks in the workflow, but to put the image on the machine, and still, I get the same error screen - message.

This seems so simple, however, there is something that is happening, and I am missing what. I have tried MDS on an old mac and a new mac, to verify it wasn’t as machine issue of some kind.

This is an amazing (and seems to be simple to set up) program, but It is not working at the minimalist level…putting an OS on the machine.

Help! what am I missing.

Normally you run the workflow selector from the recovery partition. Running from an external drive is usually reserved for special circumstances like when a recovery partition doesn’t exist or when you want to go from a later version to an earlier version.

If you do want to boot externally, can you let me know what command you run? A screen shot or photo would be very helpful.

tim

Hello Tim,

Thanks so much for responding.

I am thinking I am not explaining the process I am doing. The steps listed above were the last ditch effort to get a different result.

Let me try again, and see if this clears up my issue.

I make the usb with a workflow that images and configures the target machine. When I am done creating the usb stick, I can see all the appropriate files and folders on the “macdeploystick”. I then boot to the recovery partition, with command R and form there, run terminal, and type /volumes/macdeploystick/run. It runs …then reboots after it feels it is completed, and on the reboot, I get the apple logo with a progress bar, then I get the error screen.

I tried the two steps listed above…each one, and get the same result.

Please let me know if you need a different picture. I have included a few different terminal window shots. You can see the different command lines I have used…all ending in the same error screen.

It gets to "startosinstall prepare phase complete
waiting to reboot for 5 seconds…

Reboots, then I get the error screen.

So, it appears the High Sierra.app was corrupt. i got another download and it seems to be working now. …at least the imaging part! Will start working on the rest of the options.