Major problems with Boot Camp Assistant, is something possible using Winclone 7

OK, I have a MacBook Pro, 9,1, mid-2012. Current OS is Mojave, 10.14.6 + security updates. I have a recent .winclone image of my Windows 10 (Home) installation. So I can recover. But I was hoping to try a clean install of Windows 1909 using Boot Camp Assistant. I have tried both the .iso that Apple recommends and an Enterprise iso I got using the MS Media Creation tool using Windows.

Boot Camp assistant accepts the Apple recommended download, but shouts that there is “not enough space” on a 32 GB ExFAT USB2 drive. If I use the TwoCanoes tool for subdividing the .wim file, it says it needs a “64-bit version of Windows 10”, and fails. It gives an identical error for the Enterprise iso.

I have tried resetting SMC and nvRAM. I have verified the md5 of the Apple approved iso against what it’s supposed to be. I’ve tried creating the USB manually - dragging files and folders, and that allows installing Windows 10 - but only in EFI Boot mode, and my 2012 machine isn’t fully supported - specifically, audio drivers don’t work.

Is there anything that I can do as a workaround using Winclone? I saw a knowledge base article on using Winclone to create a .winclone file from a Windows .WIM installer. But would doing so get me any closer to being able to install Windows 10 on my 2012 MacBook Pro?

Thanks for looking.

I have not see the “not enough space” error on the flash drive. If you look at it in Finder, does it show 32GB of free space?


Yes, it still says 31.7 or something GB. Still says exFAT, so BCS didn’t surreptitiously convert it to FAT32. I have posted this on Apple Support discussions, and have been told that MANY of my current issues stem from having put in an SSD and using an OWC “Storage Doubler” so that 1) I know longer have an internal DVD drive and 2) I have 2 internal hard drives. I’ve been told that even if I successful in creating a Boot Camp USB, it will probably not successfully boot into Legacy mode, which is necessary for that model year if I expect Boot Camp audio drivers to work. I’ve already seen a manifestation of that - I was able to get a different built of Windows 10 onto a FAT 32 USB2, and I got “Windows” as an option (in addition to EFI Boot) as a boot option, but choosing it led to a black screen with “non system disk”.