MDS 10.15.5 bridgeOS error on latest 2020 Macbook Pro 13 inch

Hello,

I am hoping someone could shed some light on an issue I am facing with MDS. I can not successfully run a workflow on a newer mac we just received. The mac needs OS 10.15.5 Min to install however with both 10.15.5 builds gotten from MDS I am getting the same errors. I will attach the log below:

https://pastebin.com/bfVRZj9A

Specifically this error:

2020-06-25 20:18:24+00 MacBook-Pro osinstallersetupd[928]: Warning: couldn’t obtain xar-verified URL for http://swcdn.apple.com/content/downloads/42/39/061-34781/e1q2mivt6gvn0ek0lnt3uibgt4ugp7hjp4/OSX_10_15_IncompatibleAppList.pkg

2020-06-25 20:18:25+00 MacBook-Pro osinstallersetupd[928]: bridgeOS update prepare failed: Error Domain=BOSErrorDomain Code=110 “The bridgeOS update doesn’t satisfy the given minimum version requirement.” UserInfo={bridgeVersion=17.16.15300.0.0,0, minimumVersion=17.16.15580.0.0,0, catalogURL=https://swscan.apple.com/content/catalogs/others/index-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog, NSLocalizedDescription=The bridgeOS update doesn’t satisfy the given minimum version requirement.}

2020-06-25 20:18:25+00 MacBook-Pro osinstallersetupd[928]: Operation queue failed with error: Error Domain=com.apple.OSInstallerSetup.error Code=602 “An error occurred installing macOS.” UserInfo={NSLocalizedRecoverySuggestion=You can try again to complete the installation., NSLocalizedDescription=An error occurred installing macOS., NSUnderlyingError=0x7fbfef053930 {Error Domain=BOSErrorDomain Code=110 “The bridgeOS update doesn’t satisfy the given minimum version requirement.” UserInfo={bridgeVersion=17.16.15300.0.0,0, minimumVersion=17.16.15580.0.0,0, catalogURL=https://swscan.apple.com/content/catalogs/others/index-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog, NSLocalizedDescription=The bridgeOS update doesn’t satisfy the given minimum version requirement.}}}

To continue with my troubleshooting. I was able to get a 2018 working with the same workflow and sparseimage from MDS. I believe this is a BridgeOS update issue:
“bridgeOS updates doesn’t satisfy the given minimum version requirement”
It requires the 17.16.15580.0.0 and the update bundle package contains 17.16.15300
that is with the 10.15.5-19F2200.sparseimage I will try it again with the 19F101 however i dont expect any change since that build date is in the past

I think we discuss this in Slack, but to post here, the issue was resolved with using the latest non-forked build (19F101).

tim