MDS 100%, 1 of 1?


#1

First off, excellent job on the MDS. The videos I’ve seen make it look like exactly what we need. I’m very excited to get all the kinks worked out!

At the moment, however, I’m having some trouble. I built a workflow consisting of only the Mojave installer, and a Windows 10 package (the LTSC version, captured via Winclone 7 Pro) with nothing on it, for testing purposes. I put it all on a USB drive via the MDS, and it seemed to work… except now, the Mac is at a black screen with the Apple logo and a progress bar that appears to be about 95% full. The message keeps alternating between “100% completed” and “1 of 1”. I’ve let it go for about half an hour, so I doubt it’s still doing something. Any ideas?


#2

Update: I let it go for another 10 minutes, then powered it off and started with a fresh Workflow, consisting of the same things, but also a few more packages. Now, it goes through the same steps, but ends up at the same black screen with an Apple logo, but says “4 of 4”, and “100% completed”.


#3

Those are the packages that are installed. I would check the log (/var/log/install.log) and see what is happening. I suspect it is a package that doesn’t like to be installed silently or without a user logged in.

tim


#4

Yup, it worked. Something about that first trial took a long time, but afterward, I added about 15 more packages, and it finished in a couple hours. Much better. There’s still a handful of things I’d like to figure out (like joining to the domain via script or package, or possibly via Jamf policy at check-in), but so far, so good.

MDS is fantastic. I’ve been in charge of building our classroom Mac image for a few years, and I skipped upgrading last year because of the T2 chip, and the problems with imaging at the time. MDS makes it much easier than it used to be, so it’s a huge hit for me. Thanks for all your work on it, speaking as one of the Mac community, we appreciate it!