MDS - http mount - hdiutil function not implemented

First attempt at using MDS. Have place the .dmg file that MDS created on the Mac Mini I’m using as a server.
I can access the DMG file on a regular machine [my linux box], so I know the file is being served. I have it stashed in 2 places for testing. Both locations give the same errors.

Booted into Recovery mode on a new M1 Mac mini.
Fired up Terminal

Have tried:
diskutil mount http://IPaddress/1.dmg/Volumes/MacDeployStickResources/Run
diskutil mount http://IPaddress/1.dmg/Volumes/MacDeployStickResources/run
diskutil mount http://IPaddress/1.dmg/ && Volumes/MacDeployStickResources/Run
diskutil mount http://IPaddress/1.dmg/ && volumes/macdeploystickresources/run
diskutil mount http://IPaddress/1.dmg/ && volumes/mdsresources/run []found this one in the forum somewhere]

All give the same error - “function not implemented”.

I’ve seen several different commands to mount and get things started in the v4 docs and the forums - the big differences seem to be capitalization - so I’m a bit confused.

I’m hoping this is an id ten t error. I’m VERY familiar with those!
Anybody have some suggestions?

Quick update:

  1. figured out the “MacDeployStickResources” vs “mdsresources” - that’s what the volume is named. I [finally] saw the setting where that appears.

20 I gave up trying to get the web installer method to work. Maybe one day someone will see this is add the magic tidibit-o-info that I’m missing.

The webserver must support resume requests. i have not header of a webserver not supporting that in a long time. Try using the webserver built into MDS and see if that works.


Your posting title says “hdiutil”, but the commands you have listed say “diskutil”. The command to use is “hdiutil”, is that what you have been using? In any case, the first command mounts the .dmg file:

hdiutil mount http://<IP-address>/<filename>

The second executes the script created by MDS:


You should give that a try.


I’m using the builtin Apache server on the same MacMini.
I setup [in MDS] port 1876 to forward to the directory where the dmg sits. I can download the file onto a machine successfully, so it IS accessible.

It’s a problem for another day. My workaround was to just download the dmg onto another Mac, open it, and manually copy over the data onto a flash drive. Not exactly elegant, but I only had 4 to setup… for now!


Right - I wasn’t very clear [too much fuzz in the brain!],

I was getting an hdiutil related error in the midst of all that. I’ll give it another go when I get a chance. Got to get moving on some other projects at the moment!