MDS Imagr "Bad CPU type in executable"

Hi everyone,

Probably an issue others are running into, apologies if it was answered in another thread…

I understand that startosinstall does not work with M1 processors, per the article below… however, the article also explains that the workaround is to “Use Apple configurator or MDM to wipe Macs, then run an MDS workflow to install non-OS install packages.”

I configured my workflow to not wipe or install MacOS… but I still receive the CPU error when trying to run the workflow:

How can i run the workflow to just install my packages/profiles/scripts?

Target mac is Macbook Air 10, M1, 13", MacOS 11.0.1. Deploying MDS from a web server.

Thanks for the help

that is correct. MDS doesn’t currently work on M1 Macs. I am waiting to see if Apple support restoring from the recovery.

tim

Got it, thanks for confirming.

Does MDS support running from within the OS itself or does it have to run within Recovery?

For example, if an M1 Mac set itself up using Automated Device Enrollment via ASM/ABM and an MDM server, then login to the local admin account and call the MDS workflow via terminal.

The thought would be it would allow the non-OS packages, scripts, and profiles of the workflow to run and take advantage of the Rosetta emulation platform.

There are many issues around the M1 and Big Sur. They are outlined here:

tim

Any updates on this issue?

Yes, i am working on a SiMac version now and it looks like you will be able to install packages and scripts from recovery and it will run after next boot on a SiMac.

tim

3 Likes

This is fantastic news. Will we still be able to preset workflows on this new version?

that is the plan. Follow me on twitter if you want to see progress as it happens :slight_smile:

twitter.com/tperfitt

Thank you @tperfitt! What’s the process to make this public? I apologize if this is a basic question, just learning how to deploy using MDS.

All builds are posted here:

https://bitbucket.org/twocanoes/macdeploystick/downloads/

tim

1 Like

Downloaded and testing v4 b40046 right now, but none of the workflows I create show up on the fancy new MDS gui when launched on a machine running terminal in recovery mode. We just got 1500 new M1 MBA for deployment to students… not attempting anything with macOS installer, just a few scripts and packages.
Tested old workflows and brand new, but it just pops up a message saying “there are no applicable workflows for this mac”

Did you enter anything in the “Only show workflow”?

Tried both leaving it empty and unchecked, as well as checked with “MacBookAir10,1” specified, but still no workflows.

I was testing a workflow on a new out of the box M1 Macbook Air and was getting the “no workflows” error as well. Weirdly, I got my workflow to show up depending on how I launched MDS.
In Recovery, with my thumb drive named “MDS”, typing ‘/volumes/mds/run’ got me no workflows showing, but typing ‘/Volumes/MDS/run’ produced the valid workflows list.

1 Like

i got the same issue in a new MacBook m1 no workflow shown

That did the trick for me as well! Both the V in Volumes, and name of the external drive are apparently case sensitive.

1 Like