MDS - Setting the time-zone

For some reason after installing via MDS my time zone thinks I’m in Cupertino instead of UK.

Is there an easy way to set this, otherwise the Mac will fail to authenticate with our firewall and be unable to get the location automatically via the web.

Thanks!

Hi f1ux,

I have the same issue going on. I have a command that functions perfectly within macOS to change the timezone, but when I run it through MDS it doesn’t make the change despite stating it ended successfully. I’ve tried running it through MDS, creating a flat package, and running it as a postinstall script - and nothing changes. But again, it works flawlessly when executed within macOS and through the Terminal.

Perhaps this will help you as a workaround until a solution can be found? If you use the -listtimezones argument instead, it will display a list of all the timezones that can be set.

sudo systemsetup -settimezone America/New_York

In 1.4, there is a new option to allow location services even when skipping the setup assistant. Were you skipping the setup assistant?

tim

Has anyone found a fix for this yet? I am having the same issue…

We are investigating. I have heard that is works after the first reboot. Have you tried that?