Mds4 failed to install packages

Hi, thanks to anyone who helps.
I am new to MDS. I am using MDS4. I created a workflow, everything worked, but the workflow did not install packages. I’ve specified the package and app in MDS. All packages are pkg packages. The macOS I installed was 11.4. After the workflow finished, I tried to install the package manually, it says I need to install Rosetta to enable the application made for intel chipset work for apple M1. Is it because of this that the workflow failed to install the packages. When I install that same package on 11.3, I was not asked to install Rosetta. Forget to mention one thing, I don’t have a certificate to sign apps. From the tutorial, i saw apple Developer ID installer certificate. I am not an apple developer, so how can I get a certificate to sign apps if it is necessary.


The latest builds of MDS install rosetta to get around this issue. Try using the latest build.


Thank for your help Tim

I downloaded the latest version yesterday and had the same problem. I’m running Version 4.1 (41118). Installed only a few of my packages during the workflow and then when I went to manually installed the ones it skipped, it requested Rosetta to be installed.

Before installing packages, it runs this command:

/usr/sbin/softwareupdate --install-rosetta --agree-to-license

Is it possible there is not network so it fails? It will try 10 times with 5 seconds inbetween.

It also logs to:

That may give the answer.


Hi Tim,

Just curious, will it still run the script on just a workflow of packages or only when an OS is installed?

any of the options, packages, or scripts are installed as packages via a script. That should install rosetta.


MDS Version 4.0 (40106) here
M1 MacBook Airs.
Rosetta is not installed. Workflow that includes installing OS or not.
I’ve tried forcing Rosetta to install as a package after grabbing it from a machine that installed it, including renaming it so the package installs first.
Also tried using a hub with ethernet so the system always had internet access.
In all attempts, Rosetta is not installed and any install packages that require it are not run.

Thoughts on what I’m missing?