Migrate WIndows 10 to Samsung SSD T5

I encounter a problem when tried to migrate windows 10 from internal drive to external SSD. Wish anyone can help please.

Machine : iMac 2017
External Drive : Samsung SSD T5 (1TB) (connect with USB 3.1)
Windows version : Win10_1809Oct_v2_English_x64.iso

Problem :
When I reboot the Mac holding ‘option’ key, there are two volume options, one is mac partition, another is a volume named “EFI Boot” instead of “Bootcamp”. I just try to continue choose the “EFI Boot” volume, it just show up the windows logo and loading for 30 seconds, then reboot to Mac partition automatically.

I have already followed the steps below :

I am not using volume to volume cloning because of error message ‘block size mismatch’. I use the method “creating and restoring winclone image”.
I have run the Sysprep.
I also disable macOS SIP from the beginning.
I separate my Samsung T5 in two partition, one is 300GB, another is 700GB, I restore the winclone image to 300GB that one.

Anyone know what is the problem please ?
Thank you very much.

I responded in our help ticket system, but I’ll respond here as well.

The settings you outline are the same we use here to test (same Mac, same external drive, same version of Windows). I am not sure why there would be any different for booting. What is the error message you get?


No error message is appeared.
Every step (create winclone image, then restore it to external SSD) go through smoothly.

I think the problem may be related to the windows partition named “EFI Boot” after restore, but I don’t know what reason caused about that.

It is because I tried migrate windows 10 to external SSD successfully one year ago.
More information about that :

Machine : iMac (2017) (same as this time)
External Drive : Silicon Power Thunderbolt SSD (120GB)
Windows version : Windows 10 (which version I don’t remember)
Software : Winclone 6
macOS : macOS Sierra

After the process of creating winclone image & restoring it to SP Thunderbolt SSD, the name of windows partition in external SSD is shown as “Bootcamp” in the chosen volume screen, just like the default name of bootcamp partition create in internal drive.

The Thunderbolt SSD (120GB) is not enough for me now, so I want to migrate to a new one (Samsung T5). Hope for help. Thanks.

It does seem like it might be this external drive. Different drives present themselves differently to Windows, and it would be driver related.