Munki not working


I am trying to set up munki, and following the video. All was going well, until I selected save on adding an optional package. When I opened the managed software center on a local machine, I also get an error. Thinking there is an issue with the setup of the server component.

Have you tried running Munki from the command-line with the verbose option? That or consulting the Munki log on the client should give you more information as to why it’s failing.

For test purposes, I’d configure Munki by hand on a test system to see what happens. Use defaults write to create the configuration.

If it doesn’t work, head over to the Munki Google group for assistance.



so I have made some progress, but I am still a bit stumped.

I have attached the log, error message, and a screenshot.

I am thinking the machine doesn’t know what manifest to use…based on the error, and not sure how to associate that with a client machine.

The screen shot shows the log, that I can type into the web the munki server and it gets to my files. and that when I do a "sudo launchctl list | grep munki, I get the proper results. yet i can’t see any software in the managed software center.

I am a new mac support person, and trying to get this up and running for the next school year. The possibilites are amazing with the program. Just missing something with the manifests, and how you assign them to clients.



(Attachment errors.log is missing)

(Attachment errors.log.1 is missing)

(Attachment ManagedSoftwareUpdate.log is missing)

(Attachment errors.log.0 is missing)

(Attachment errors.log.2 is missing)

Hello J Duke.

I replied, but the attachments were not allowed.

1.I believe I have the muni server working, however, I am not getting a certificate error when I try to access the managed software center.


Jun 11 2019 13:56:22 -0700 ### Beginning managed software check ###

Jun 11 2019 13:56:22 -0700 Checking for available updates…

Jun 11 2019 13:56:22 -0700 Getting manifest site_default…

Jun 11 2019 13:56:22 -0700 Download error -1202: The certificate for this server is invalid. You might be connecting to a server that is pretending to be “” which could put your confidential information at risk.

Jun 11 2019 13:56:22 -0700 SSL error detail: (-9813L, u’Cert chain not verified by root’)

when I type the web ip in the browser, I get a “this connection is not proves……same thing …impersonation. i can force it, but that doesn’t do my students any good.

I created a certificate within MDS, and have pointed it to the cert, that I just created for HTTPS: It is valid. I even tried to import that cert on the client machine, and no effect.

  1. how can I tell the client machine which manifest they should be looking at….when I “image” the machine? I can force it with a command line, on each machine, but it doesn’t seem to populate to the system, multiple users. maybe I am not making the connection between the manifests, and the imaging MDS creation?

Thanks for your time,


Lauren Saar

Systems Support Analyst


mail, letters, faxes, and other correspondence with the district are subject to public disclosure under the Arizona Public Records Law unless the content is exempt from disclosure by a state or federal law.

If possible it might be worth trying to go back and create a fresh Munki repo, new MDS workflow, and rerun the workflow on a fresh machine. When testing this feature for MDS I’ve seen the possibility to set something wrong without noticing, then get an unexpected result. For example: importing a workflow from another machine, selecting the wrong location when creating or adding the certificate to MDS preferences. Below is the procedure I use when testing:

From the main MDS window click the checkbox to enable “Serve Munki…” and follow instructions to install Munki Tools and create a Munki repo folder.

Open MDS Preferences and follow instructions to enable hosting Munki repo using TLS. Before running the commands in Terminal, make sure to change Terminal to the correct location by using the “cd” command and dragging in the folder location for the certificate. Then close Preferences, uncheck “Serve Munki” and then recheck it. Confirm the link shown below this checkbox can be clicked and the address shows as “https”.

From the top toolbar click the button to launch Munki Admin (download and install the app from the autoloaded page if needed). From the File menu click Open Repository and choose the repo folder recently created. Then click “File > Import Items” and add an example package to be installed on target machines, such as a package previously created by MDS for an application added to the Resources tab. Click Save twice when prompted to save the imported package. Click “Save” on the top toolbar, then quit and relaunch MunkiAdmin. Next from the Window menu select “Manifests”, then double click on “site_default”, and on the new window shown go to “Managed Installs”. Click on the “+” button near the bottom and add the package recently imported. Next go to the “General” tab and check the box in the Catalog section. Close this dialog window, then click “Save” on the top toolbar.