New 16" MBP with Sansung X5

My config is a 16" MBP with all Catalina updates. Trying to do a fresh Windows install to my external Samsung X5. I’m getting the same INACCESSIBLE media error others get trying to move a partition.

I was never able to get bootcamp to install directly to the X5. Someone online suggested installing to the internal drive and then using Winclone to my X5. That process seems to work but blue screens when booting from the external drive.

Should the steps documented to save partitions moving from pre T2 macs to the T2 machines work? In my case there is no old pre T2 partition. I’m looking to install a fresh copy of Windows. Seems like the driver situation would have been worked out on the internal drive since it booted fine and bootcamp was able to install the drivers.


We have successfully booted Windows externally on T2 Macs using this process:


Hi Tim, I followed that article. Still didn’t work. My old MBP was a 2017 and I was able to boot Windows from a Samsung T3. The X5 is not working for some reason. The OS lists it as internal? Would love to know if anyone has it working on that drive.

Having about the same issue. 16" 2019 Macbook Pro. Installed Windows 10 on a bootcamp partition and it works as it should. Couldn’t get the clone to work from there, but got Windows 10 working on a USB-C 3.1 SSD externally. Cloned that to a Thunderbolt 3 Samsung X5 NVME SSD.

When I boot to the Thunderbolt drive I get “INACCESSIBLE_BOOT_DEVICE” BSOD. Used “diskpart” to get the proper drive letter assignments and tried the instructions in the related article to include injecting the drivers from the BootCamp folder as well (a little over 100 .INF files all together). When I restart and attempt to boot from the external TB drive I just get the same BSOD. Seems like the drivers aren’t getting to the drive, or get wiped during the restart, or don’t load before the drive is attempting access.

Any ideas/further fixes?

If you get this working, please report back. There is an obvious problem with this hardware combo…I think it has to do with the OS (mac and Win) seeing these drives as internal even though they are external.

Certainly. Though unless Tim or someone else has a suggestion, I’m about out of ideas. Just frustrating because everything seems like it should work and products like Winclone and WintoUSB are advertised as being capable of doing this but it seems that’s not true. Seems like the thunderbolt driver isn’t loading on start up seeing as I was able to get it working on a USB 3.1 SSD, but not the thunderbolt drive. If nobody else has any suggestions I’ll probably just go with an internal boot camp partition of reasonable size and the thunderbolt drive as storage and just deal with the internal storage loss. Haven’t seen anybody who’s been able to get this working on a recent MBP.

i think eventually this will work. I think it’s the drivers or that thunderbolt driver is not loading correctly at boot. enough of these drives will get in to the channel and people will make noise about it. Someone good at debugging boot up can solve this. We need the Winclone guys to buy an X5.

I just placed an order on Amazon for the X5 drive and we will do some testing to see if we can get it to work.


1 Like

Awesome news…thanks for the help!

Hi everybody…
X5 situation is little bit different on OsX and Windows 10. OsX sees thunderbolt disks as external but Windows 10 sees thunderbolt disks as internal disk. That means you don’t need for Win booting any WinToUSB or any cloning tools.
To cut story in short…
You don’t need boot camp for install Win 10 on x5 disk. Just use BC assistant to download drivers for your machine and save it to some USB disk. Install Win 10 from USB/DVD media as on normal PC. After installation boot with option key directly into Windows and install BC drivers from your prepared USB. That is all.

I use X5 Win 10 for almost a year without any problems.

BTW: You will need wired USB keyboard and mouse for Win installation because internal keyboard and mouse don’t work until you have all windows drivers in place.

@Mrgud Tried it before but I tried it again just now to be sure. Got to the setup screen and selected my X5 drive (931GB partition, Disk 0 Partition 2 in my case) that had a copy of my working USB-C Windows 10 install on it. Selected the Upgrade option and was told upgrade couldn’t be done when running from an installation media. Selected the custom option (to install windows only) and got the error: “We couldn’t create a new parition or locate an existing one. For more information, see the Setup log files.”. I the tried the “Format” option on that partition then selected “Next” and got the same error. Restarting to OSX and taking a look at the X5 drive shows that the entire drive (999.63GB) was reformatted to NTFS.

I’ve seen videos of people getting all of this to work on Thunderbolt drives, but they’ve all been on older MBPs, not the 16".

Hi Melfox
As I remember I have to use “virgin” disk. That means no partition at all on this disk when you try to install Win 10. My disk is X5 500gb and I have delete absolutely all partition from disk before trying to install fresh copy of Windows 10 Pro. After that I boot from DVD and proceed installing on unallocated space (eg. unallocated space on complete disk) allowing Windows installer to partition disk and make all what it needs. EFI partition on Win and OsX are different so that is maybe problem with your way to install fresh Win directly.
Best way to completely clean disk is “diskpart” command from terminal that you can find on Win 10 installation media if you goes to the repair section before proceed with installation.
Here is how:
If you need more info feel free to ask.

NOTE: I didn’t find a way for my OsX to see this new Windows installation so you can’t select windows in “startup disk panel” from OsX but Windows bootcamp control panel sees OsX so you can select startup disk from there or you can select just OsX startup disk from Catalina. Anyway, You can always use option key while booting and there will be all OS disk presented.

NOTE2: I don’t think your problems have anything with MBP 16" machine because this comp have essentially the same core as MBP 15" from 2016-2019.

@Mrgud Followed your link and deleted the primary partition. Had to run a clean all command (which I stopped after I found out it would take about 3.2 hours to complete) to get rid of the protected system partition possibly left over from using WinClone previously. Even with the stop, it still appears to have gotten rid of all partitions and Disk 2 appeared without partitions listed as “Unallocated Space”. After I did that, I was able to go through the install process “successfully”.

However, upon restart into windows on the X5 drive, I get the good old BSOD INACCESSIBLE_BOOT_DEVICE error, so back to square 1 after I had copied the working USB-C Windows 10 install using WinClone. To cover my basis, I figured I’d go through the steps to inject the drivers again (however, this did not work when I was at this step previously).

However, for whatever reason, now the only disk and volume that appears under Diskpart is the Recovery USB and only one EFI is listed on the option restart (previously there were 2 EFIs, 1 for the USB and 1 for the thunderbolt drive). My Bootcamp partition on my internal disk, my OSX Partition, and the Thunderbolt drive do not show up. Previously, this was usually caused by having an extra file on the USB (like me moving the thunderbolt drivers to the front of the file stack), but everything is in place this time. Tried restarting into the USB again and same result, only the USB Install volume shows up and there’s only 1 EFI listed on the option restart, so I can’t inject the drivers at this time.

Am I missing any steps you did?

Hmmm hmmm… In previous posts you write that your X5 is “disk 0 part 2” and now you told that you have delete all partitions on “disk 2”? I hope you didn’t erase wrong disk drive!!!

I have never use clean all command and for diskpart “delete partition” command run time is under 1 second. What I do is select disk (RIGHT ONE! :slight_smile:) and then select partition one by one to commit delete command. After that I have clean disk to start installing. When disk is clean I have restarted comp and start installation procedure from beginning. I was installing from DVD.

You wrote that you have gone through Win install process successfully so I assume that Windows didn’t complain about anything and finished installing without any errors. This means that it is possible to have working windows on MBP 16" without any specific drivers because windows installer alone actually use windows base drivers for VGA screen resolution, USB, disk I/O, keyboard, mouse, etc… After that kind of installation it should be possible to boot into windows with VGA resolution, wired keyboard and USB port where you can stick specific drivers for MBP 16". This should work and it worked for me on MBP 15" i7 (2017) with T1 chip and enabled SIP.

It is very strange that you don’t see all disks under DISKPART util and in your position first what I will try is to disable SIP from recovery. To do that turn on MBP and keep pressing COMMAND+R. After recovery starts go to terminal and execute CSRUTIL DISABLE.

Then I will try to go again through installing process and clean X5 disk (without stoping any commands!). Do that step by step with diskpart util from Win install media. Then install windows and if there is no errors reboot into this new windows.

I don’t know exactly what and how T1 or T2 chip or SIP works but at least this way you will take SIP out of equation for sure.

According to this article SIP and T2 chip works together and T2 chip is connected to boot processes so my idea is to turn off the SIP and try installing Windows that way. Maybe I am way out of solution for problem but who knows. :slight_smile:

@Mrgud Yeah, I’m not sure why it changed. Maybe because I had switched which port it was plugged into. Each time I use Diskpart I list disks, partitions, and volumes to ensure I’m acting on the correct on. The X5 drive is the only one partition any where near 1TB I have connected (32GB Flash Drive, 2TB internal drive with 400GB for bootcamp and 1.6TB for OSX) so I can verify by the disk/partition/volume size.

I did about 4 tests as part of following your directions. One involved deleting the partition as you said. I did that and didn’t touch the EFI partition, but got an error saying that the EFI partition was detected as NTFS and needed to be FAT32, causing me to run Clean All to get rid of it assuming Windows would create a new one, but maybe it doesn’t considering an EFI boot doesn’t show up for it on the option start now. How does your external boot show up in the option restart? And do you have an approx 500MB System partition on that drive as well as your primary partition with Windows 10?

Can’t use a DVD since the install file seems to be over 4.whatever GB in size, but I don’t think the USB is the problem. I already disabled SIP as one of my initial troubleshooting steps several days ago. I’ve also enabled boot from external device.

You are correct, no errors through the install process up until it restart to boot from the new install. That was where I got the BSOD. I have Win10 working on an internal bootcamp partition and an external USB-C SSD. It’s just the TB3 NVME SSD that’s giving me problems.

Since I’ve gotten SIP taken care of, the only thing I can think of trying again is to format the X5 drive from Disk Utility again to try to get it to show up in diskpart, clone the USB Win10 over, check that the EFI is FAT32, delete the primary partition again, and if that doesn’t work run a Clean command to wipe everything and try again (Clean should only take ~15 minutes).

EDIT: Recreated my internal bootcamp install and the install USB. Only the USB is appearing in Diskpart when I boot from it still. However, everything shows up when I boot into my internal Bootcamp partition.

Got new internal bootcamp partition, cloned the USB C working SSD to the Thunderbolt drive, deleted the primary partition in from the internal bootcamp partition, remade the install USB, and got some error about windows couldn’t boot something or another when it attempted the install.

Took a look at diskpart and saw all of the volumes to include the extra ones that the install makes. Ran the clean command on disk 2 (X5) and allowed it to complete then checked volumes and saw disk 2 as 1 volume and empty. Went back into the install, selected disk 2 (which displayed as 1 volume of unallocated space) and it allowed me to get through the install up to the restart. At the restart I once again got our old friend INACCESSIBLE_BOOT_DEVICE BSOD and once again only the Install USB is reported in diskpart so I can’t even inject the drivers manually.

All in all, I’m tired of dealing with this. I’ve given myself a 300GB internal partition and for the time being I’m going to use my X5 drive as an external fast storage drive. Less than ideal, but I’m tired of trying things again and again that don’t work. I think I’m going to wait until the WinClone folks give it a shot before I try anything else unless @Mrgud you have anything I missed. I appreciate all of the ideas and assistance though.

EDIT: As a side note, after all of these steps, my internal bootcamp partition has once again stopped working and gives me a BSOD upon booting, so back to a reinstall again.

My option boot is like on photo:

First internal “windows” disk is because of boot camp assistant error since APFS and Mojave fresh installation. I try to make boot camp partition at that time but there was errors in fresh Mojave APFS so I have never been able to finish installation. After that I take X5 and install win 10 directly without BC assistant. X5 is yellow disk. I should correct internal boot list to point on X5 but never have time to do that…

In next two photos X5 is disk 1 and you can see all partitions that windows installer made without any intervention from my side. Disk 0 is internal MBP Apple disk and other disks are configured and formatted in OsX. Some of them are APFS partitions, some NTFS and some HFS+

You can see different sizes of EFI partitions. 300MB for internal Catalina disk, 260MB from Windows 10 installation and 200MB for disks that was made from OsX. Also, there is two reserved partitions on windows disk…partition 2 - 16MB reserved (don’t know for what) and Windows recovery partition 517MB at the end of the disk.

Did you try to repeatedly press F8 key (while booting Windows) to boot into recovery mode and choose safe mode and try device manager to fix drivers while you are in safe mode? Or that way you also got BSOD?
Also, once I had problems with TB3 cable quality and it give me a lot of headache. Change cable that you use for X5 and try it. But I don’t think it will help because too much people have the same problem and the same INACCESSIBLE_BOOT_DEVICE BSOD.

Actually, I don’t think you have a driver problem neither because you have fresh installation without any drivers and installer actually works with that base drivers. Windows should also work with the same drivers it use for installation. It could be a driver problems if Windows pull drivers from internet while installing but then you will be able to take F8 way to recovery and fix that problem from inside of Windows OS. Also, any possible problem with T2 or SIP would not give you enough authority to install at all…I guess…

Interesting. That about matches the partitions I had as well, except no boot. Boot list is a little different seeing as I have Windows, Macintosh, EFI (recovery USB), and sometimes rarely EFI (Thunderbolt 3 drive).

I don’t have another thunderbolt 3 cable to test, but I doubt it’s that too. Everything is super consistant and repeatable. I tried all 3 safe mode options the first time I got inaccessible boot device and got the “boot failed too many times BSOD” (safe mode, safe mode with command line, and safe mode something or another). None of those got me past the inaccessible boot device.

I highly doubt it’s SIP considering I turned it off on day 1 of trouble shooting. Only thing I can think of is it’s either some driver boot order that has windows looking for the boot drive before the thunderbolt driver loads (as I said, I have an external USB-C SSD that works just fine from the same port) or there’s some internal difference between the 2017 MPB and the 2019 16" MBP that has it working just fine for you and failing for many other people. But then again I don’t really know a whole lot about how computers work behind the scenes apart from my research on this issue.

Either way I appreciate the help @Mrgud, but I have wasted way too much time and effort on this. I’ll just wait and see if something changes down the road and use it as a storage drive for the time being.

EDIT: Guess I can’t reply again for some reason, so @tperfitt Thank you for the update and the clarification. Wish it had been doable, but good to know that it’s actually not working and not just me messing something up.

So I got the X5 working for some Macs, though not all that I could test on. I didn’t have to inject any drivers to get it working on macs that work, and driver install did not seem to make much of a difference on Macs that don’t work. Here is what I tested on and worked:

Windows 10 1909

MacBook 13,1
MacMini 2018
MacBook Air 2018

Did not work:
MacBook Pro 16"

I spent a bunch of time trying to figure out what the issue was with the MacBook Pro 16". When I tried to use the installer, it failed with a “EFI partition not FAT” (though it was) and “wrong size for EFI partition” (I tried increasing the size without success). I also tried having the internal EFI partition point to the external drive to boot, but that failed with the same error as well. I was successfully in getting the Thunderbolt driver to load when booting from a flash drive with the Windows installer and running drvload \path\to\Thunderbolt\Driver.inf. However, that didn’t help with the installer or the clone. It is almost like it doesn’t see the Thunderbolt driver as a mass storage driver so does not load it.

I’ll update the Winclone external booting article to reflect these findings, but the X5 does appear to work, but only in certain situations on certain hardware.


1 Like